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Foreword 

 

Dear Participants, 

First of all, I would like to extend my warm welcome to you all to this in-country training workshop for 
Uganda. The Greater Horn of Africa region is a land of contrasts. If you look at the two most common 
hazards in the region, notably droughts and floods, they are characterized by severe shortage or excess 
rainfall, respectively. Disasters pose multifaceted challenges in our region. Drought, for instance, is a 
phenomenon that not only puts the lives and livelihoods of the communities in the region at risk but also 
destroys the hard-earned development gains of communities and countries at large. The resources that 
countries are investing for years in drought disaster response and recovery could have significant 
contributions to advance sustainable development. There is a strong need to put in place all the 
necessary mechanisms to prepare for and respond to disaster risks. One of such a mechanism is 
understating hazards/risk and putting in place monitoring and early warning systems that would enable 
us to reduce their adverse effects. 

This training is organized with the objective of strengthening the capacity of national DRM institutions and 

relevant sector ministries through technical training on hazard assessment, monitoring, and early warning 

using Earth Observation and GIS. Such technical training sessions provide a platform for sharing good 

practices in disaster risk reduction across the different sectors. In this five days training, you will have 

practice sessions and also an opportunity to discuss recent methods and tools in hazard assessment 

which are believed to strengthen the national disaster risk reduction efforts.  

  

The IGAD/ICPAC DRM Program will continue to strengthen regional efforts to develop DRM strategies 

and capacity development of the Member States. The program is implementing several projects in 

collaboration with development partners to support regional and national efforts towards an effective 

disaster risk reduction and resilient region.   

  

With those few remarks, I wish you a successful training workshop and I assure you our continued support 

to strengthen national DRM institution to achieve effective disaster risk reduction as enshrined in the 

global, continental and national DRR strategies and frameworks. 

                              
  
  

Dr. Guleid Artan, 

Director 

IGAD Climate Prediction and Applications Centre (ICPAC) 
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MODULE 1:  
INTRODUCTION TO GEOGRAPHIC INFORMATION 

SYSTEMS (GIS)  
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1.1. Theories and Concepts of GIS  

Learning Objectives: At the end of this module you will be able to;  

 

● Understand the theory and concepts of GIS  

● Get familiar with ARCGIS software along with geoprocessing tools and spatial analysis  

● Identify main open GIS data sources that can be used for Disaster Risk Management(DRM) 

● Baseline data analysis and information extraction in ARCGIS    

1.1.1 Introduction 

Geographic Information System (GIS) helps to manage spatial and non-spatial information in a very 

efficient way. Properly managed data and information helps in better territorial planning and decision 

making. In GIS, data about real-world objects is drawn quickly and can be displayed using the different 

attribute fields stored in GIS databases. A typical GIS data is shown in Figure 1.  

 
Source: Senseable City Laboratory, MIT 

1.1.2 Source and Nature of Spatial Data 

The sources for spatial data can be from different sources including Field observation/measurement, 

GPS based data collection, Remote sensing and software based derivations like map digitization. Now 

days Satellite based data acquisition is providing continues image products for almost all areas of the 

world at different spatial resolutions. The field based data collection also remain important in providing 

ground based accurate measurements which often helps to calibrate space based products.  
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1.1.3 GIS Data Models and Coordinate Geometry   

The nature of the spatial data can be of vector or raster format. Vector data formats are used to represent 

discrete type of data and often represented by point, line and/or polygon. Raster data types are used to 

represent continuous data types like rainfall, temperature, topography...etc. The smallest entity of a vector 

is a point whereas for raster it is a pixel. The type of data modeling depends on the nature of the data, 

scale of the map, and our preference for the analysis that follows. However, it is good to remember that 

conversion of raster to vector or vise-versa is always possible although it might compromise the 

quality/form of the original data. For example, if you convert a raster to vector the edge may be 

generalized and may not follow the exact boundaries. It is highly recommended to avoid back and forth 

conversion of your data between vector and raster unless you are required to do so. It is also worth to 

remind you the many raster file formats which sometimes creates obstacles to data processing as all data 

formats are not compatible to the software’s we may choose to use.   
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Attributes shows characteristics of a feature; any additional information that are associated with each 

vector feature such as land cover class or area or administrative division. So every field (column) in an 

attribute table refers to the attributes. Raster consists on only of a cell value associated with that pixel.  

Coordinate systems: Any data that represent the location/position is called spatial data.  The most 

common ways of representing spatial data is through the use of X and Y or longitude and latitudes 

which are obtained through the system called coordinate system. There are two categories of 

coordinate systems and these are Geographic coordinate systems (uses degrees minutes and 

seconds) and projected coordinate systems (uses meter as a unit of measurement often with six/seven 

digit numbers).    

a) Geographic Coordinate Systems 

It uses Latitudes (0-90oN-S) and Longitudes (0-180oE-W)  and the Latitudes are measuring the distance 

from the equator( Y-dimension) and Longitudes are measuring distance from Greenwich (X dimension) 

either be positive on the north hemisphere or negative on the south Side of the equator are measured 

using degrees, minutes and seconds (° , ‘ , ’’). 

 

b) Projected Coordinate Systems  

This system by Mercator divides the globe in to 60 grids called zones and uses meter as a unit of 

measurement.  
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 Introduction to ARCGIS  

1.1.4 Brief Introduction to Geospatial Technology 

Geospatial refers to a technology/advancement made in the areas of spatial data capture, processing, 

store, visualize, present and sharing using both hardware, software and methods. The advances made 

in space technology opened the way for spatial data capture which revolutionizes the geospatial world.  

Recent advances in space born and air borne (including drones) technologies make the way for high 

resolution data capture in near real time. 

GIS helps to manage spatial and non-spatial information in a very efficient way. Properly managed data 

and information helps in better territorial planning and decision making. In a GIS, data about real-world 

objects is drawn quickly and can be displayed using the different attribute fields stored in GIS databases. 

ArcMap is one of the main component of ESRI’s ArcGIS Desktop software package, and it is used 

primarily to view, edit, create and analyze geospatial data. ArcMap allows the user to explore and analyze 

data from different datasets, symbolize features accordingly, and create maps. 

1.1.5 Learning Objectives  

By going through this exercise you will become familiarized with some basic tools and functionalities of 

ArcMap and you will be able to: 

➢ Recognize ArcMap interface and toolbars 

➢ Add, Manipulate data layers and attribute tables 

➢ Download baseline data. 

➢ Label features, create spatial bookmarks and save a map using relative path 

➢ Create an Area Of Interest known as AOI. 

➢ Clipping baseline data to AOI.  
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GLOSSARY 

Geographic Information System (GIS): A system for capturing, storing, checking and 

displaying data related to positions on Earth’s surface. GIS can handle data as several layers, 

in two predominant data models. 

Raster consists of matrix of cells (or pixels) organized into rows and columns (or a grid) 

where each cell contains a value representing information, such as temperature. Rasters are 

digital aerial photographs, imagery from satellites, digital pictures, or even scanned maps. 

 

 

 

Source: ESRI 

Vector consists of geographic features such as point, line and polygon. 

Source: ESRI 

Attributes shows characteristics of a feature; any additional information that are associated 

with each vector feature such as land cover class or area or administrative division. So every 

field (column) in an attribute table refers to the attributes. Rasters consists on only of a cell 

value associated with that pixel. 

Layer Files (layer_name.lyr) saves all of the symbolization (colors, symbols etc) and 

labelling that you have defined for that layer. Layer files do not contain the actual datasets. 
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STEP (1) 

Basic Geoprocessing and Spatial Analysis  

1.1.6 Getting Familiar with ArcMAP 

● Start ArcMap by double-clicking on the ArcMap icon on your desktop . If an icon is not 

present, you can use the Start Menu: Programs > ArcGIS > ArcMap. 

● You can specify, whether or not to start with a new empty map, a template or an existing map 

We will start this exercise by opening an empty map document: 

● Select Blank Map and click OK. 

1.1.7 ArcMAP Interface and its main Elements 

Your ArcMap window should look similar to the one shown below. Do not worry if the interface displayed 

on your screen looks different. The toolbar will probably have a different layout but it may be easily 

customized according to your needs.  

 

1.1.8 Set Data Frame Properties  

From the Data Frame Properties dialog box, you can set the reference scale of your map, map units, 

coordinate system and assign a name to the data frame. 

● From table of contents, right click on the data frame name “Layers” 
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● Select Properties > General tab 

● In the Name section, type “UG_data” 

● In the Units section, select Decimal Degrees for both Map and Display Units and click Apply 

 

● Select the Coordinate System tab and notice that no projection is selected 

● Expand the Geographic Coordinate Systems > World > WGS 1984 

● Click Add to Favorites (so it will be easy to find next time) and click Apply >then OK 

 

Note: To display data correctly, each data frame uses a coordinate system which determines the map 

projection. The data frame coordinate system might be different from your layers coordinate system. 

ArcMap can project your data on the fly, but it can take longer to draw. 

When ArcMap is started with a new, empty map, the coordinate system for the default data frame is 

not defined. 
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 STEP (2) 

Working with Baseline data  

1.1.9 Add data into ArcMAP 

● From the standard toolbar, click the Add Data button  

● Browse to: X:\UG_data\Module1\Admin 

● You might need to connect to the data folder for this exercise by clicking the Connect to Folder 

button in the Add Data dialog box  

● From Admin Folder, select UGA_adm1.shp and UGA_adm2.shp. You can select multiple files 

by pressing “Ctrl” key while selecting the files. 

 
The selected layers are added to the Table of Contents and displayed (if checked) in the Data View. 

Layers are displayed with random colors and can always be changed. 

1.1.10 Change Layer Color  

The layer’s symbol is the point, line or rectangle displayed below the layer name in the Table of Contents. 

To change the color or the size of a layer: 
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● Double click on the symbol(s) below the layer name. 

● From the dialog box that appears, select your preferred color. 

● You can also edit an existing symbol and save it. 

 

1.1.11 Arrange the Table of Content  

Data layers are drawn in the order they appear in the Table of Contents. Layers at the bottom are drawn 

first and layers at the top are drawn on the top of the map. If a layer on top is hiding a layer underneath 

you may not be able to see the lower layer. 

In the Table of Contents, you can move a layer up or down by dragging it to the desired position. 

1.1.12 Creating a Group Layer 

To improve the organization of the different data layers, you can create Group Layers to sort your data 

by category. A Group Layer behaves similar to other layers in the Table of Contents. To create a Group 

Layer: 

● Right click on the Data Frame > New Group Layer 

● Right click on the new group layer and select Properties 

● Enter “Administrative Boundaries” as Layer Name. You can change the name of the new group 

layer by single left click 

● Select “Show layer at all scales” and Click OK 

● Drag the displayed layers into the “Administrative Boundaries” Group Layer. 

1.1.13 Zoom and Pan 

 Use the ArcMap toolbar to zoom in, zoom out and pan over a region of interest within the data view. 
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Notice that as you move the cursor around the map, the cursor position displayed at the bottom left of 

ArcMap window changes respectively. 

1.1.14 Labeling Features  

Labels are text items on the map that are dynamically placed and whose text values are defined from 

one or more feature attributes. 

● Right click on one of the Admin layers > Properties and choose Labels tab 

● Check Label features in this layer 

● Select “Label all the features the same way” 

● Select label field that is the most appropriate. 

● Click Symbol… 

● Select from the Symbol Selector dialog box one of the predefined text labels 

● You can always modify your text labels by changing color, size and style. Click OK 

● Click Apply and OK 

 

● Right click on any layer, check or uncheck label features to have it on or off 
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1.1.15 Creating Spatial Bookmarks 

To save a specific extent of the map, you can use Spatial Bookmarks. Once saved, you can click the 

Bookmark button from ArcMap main menu bar, point to the saved bookmark and the map display will 

automatically zoom to that extent. 

● Zoom to one place of interest (choose any region(s) from UGA_adm1.shp) 

● From the main menu toolbar, click Bookmarks > Create 

● In the Spatial Bookmarks dialog box, type the name of the place you have chosen 

● Zoom to full extent  and then click Bookmarks > “placename” 

 STEP (3) 

Information Extraction  

1.1.16 Measure Distances 

To measure horizontal distances on your map you can use the Measure Tool. 

● Add “UGA_towns_2009.shp” data to ArcMAP from X:\UG_data\Module1\Baseline_data 

● We want to measure distance between two points. 

● From the ArcMap toolbar, click the Measure button  

The Measure window opens with the measure line tool enabled as shown below 

 

● Click the Choose Units button and choose Kilometers for distances 

● Identify two points in Gulu district that you want to measure their distance  

● Click once to fix the line’s starting point and move your mouse to the desired ending point 

● You can see the distance automatically appearing in the Measure toolbar 

What is the Distance between Point 1 and Point 2 in Kilometers? ________________ 
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1.1.17 Identify Features 

To display the data attributes of a map feature, click over the feature with the Identify tool. 

● Zoom to full extent  

● From the ArcMap toolbar, click the Identify button  

● Click inside any boundary 

 

The identified feature temporarily flashes and its attributes appear in the Identify dialog box 

● Right click on the layer in the Identify window and click “Zoom to” 

● Choose the Identify from: to be the layer that you want to work with 
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1.1.18 Create an Area of Interest (AOI) 

One of the key steps in managing and analysing geospatial data is to identify one or more areas of interest 

(AOI) which allows you to focus and limit your search over a specific area. 

● Click on Customize menu > Toolbars > Make sure Draw tool is checked 

● By using the drawing tool, Click on  and draw a new rectangle so that Nakaseke County 

(UGA_adm2.shp) falls inside the rectangle (Click on the top-left vertex and drag to the vertex in 

bottom-right corner) 

● From the Drawing toolbar click Drawing > Convert Graphics to Features, activate 

“Automatically delete graphics after conversion”. Name the output layer as 

“AOI_Nakaseke_County.shp” and save it on: X:\UG_data\Module1\Output 

 
● Click Yes in the next dialog box to export the layer. 

● From the table of contents, double click in the icon of the layer you just created and change the 

layer style to hollow and outline red. 

What is the purpose of creating an AOI layer? 

----------------------------------------------------------------------------------------------------------------------------- ---

-------------------------------------------------------------------------------------------------------------- --------------------------- 

1.1.19 Select Features 

This tool lets you select the features on which you want to perform certain operations (e.g. move, delete, 

edit, copy, etc.). You have multiple options for selecting features (i.e. by rectangle, circle, polygon, etc). 
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NOTE: In order to make the layer of interest to be the only layer that could be selected, right click on 

the layer > Selection > Make this the only selectable layer. 

● From the ArcMap toolbar, click on the Select Features button  

● Hold down the shift key on your keyboard and select few features in any layer by clicking on 

them.  

● From the Table of Contents, right click on the feature of interest 

● Go to Selection > Create a Layer from Selected Features 

 

At this stage you cannot edit the selected features (you will learn later how to edit features later), but you 

can perform some basic operations such as zoom and pan, clear and switch selection and create new 

layers from selected features. 

● Click on the Clear Selection button  

● Uncheck the Administrative Boundaries group layer 

● Right click on the layer created from selection 

● Click on Zoom to layer 

NB: The layer you have created is stored by ArcMap as a temporary file. If you want to create a new 

dataset from the selection you need to export the layer: 
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● Right click on the layer > Data > Export Data… 

 

● In the dialog box, under the title, ‘Use the same coordinate system as’ choose “this layer’s 

source data” 

● Save the file in the following location: X:\UG_data\Module1\Output 

● Name the feature class to export as “Practice_Selection” 

● Save as type “shapefile” and click save then click OK 

A prompt window will ask you if you want to add the exported data to the map as layer 

● Click Yes and explore the newly created dataset (zoom in, pan and identify features). 

When you are done, remove the two data layers that were created from the selected features 

● Right click on the layer > Remove 

● Check/activate the Administrative Boundaries group layer 

● Right click > Zoom to layer 

1.1.20 Working with Attribute Tables 

In GIS, a feature on a map may be associated with lot of information (attribute values) stored in a table. 

A layer’s attribute table contains a row (or record) for each feature and a column (or field) for each attribute 

or category (attribute field). 

To explore the attribute of a layer, open its attribute table to select and find features with a particular 

value. 

● Right click on “UGA_admn2” administrative layer 

● Click Open Attribute table 

The table opens, containing one record for each division. The FID field contains a unique identification 

number for every record (or every feature in the map). The intersection of a record and a field is a cell. A 
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cell contains an attribute value. The total number of records stored in the table is displayed at the bottom 

of the attribute table. 

With the selection tool, select one or more records/features from either the Attribute Table or the Data 

View (from the map). 

 

Notice that when a record is highlighted in the table, its corresponding feature is highlighted on the map 

(and vice versa). 

● Right click on the selected record from the table 

● Click on Zoom to selected or Click on this icon  

To sort attribute values stored in the table: 

● Right click on a field name and click Sort Ascending 

By clicking on the Options menu  on the top of the attribute table, you can perform more operations such 

as Find and Replace, Select by Attributes, Clear Selection, Switch Selection, Add Data, and so on. 

1.1.21 Advance Selection  

The Select by Attributes dialog box allows you to select features on a given layer using a SQL 

expression.  

● From the Main Menu Toolbar, click Selection > Select by Attributes 

The Select by Attributes dialog box appears 

● Select “UGA_admn1” under Layer 

● Select Create a new selection 

● Select the attribute field "NAME_1" and 
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● Double click on "NAME_1", click “=” and click on Get Unique Values. 

A list with all the values will appear. Double click 

on an area of interest from the right. Scroll down 

to find your area of interest e.g. 'Soroti'.  

In the dialog box below, the expression should 

appear as follows: "NAME_1" = 'Soroti' (Choose 

a region of your interest, Ex: ‘Gulu’). 

● Click Verify and then click OK 

● Click Apply 

● From the Main Menu toolbar, click 

Selection > Zoom to Selected Features. 

● Click Clear Selection and then Full 

Extent. 

NOTE: You can select more than one region using 

the IN function as shown below: 

"NAME_1" IN ('Bugiri' , 'Bundibugyo' , 'Gulu', 

'Hoima' ) 

The Select by Location dialog box lets you select 

features based on their location relative to other 

features. You can use a variety of selection methods to select the point, line, or polygon features in one 

layer that are near, or overlap the features in, the same or another layer.  

We will now select places that are located inside our boundary. 

● From the standard toolbar, click the Add Data button. Alternately you can also drag and drop 

using the Catalog Window. 

● Select the UGA_towns_2009.shp from Baseline data in Module1 folder (same as above). 

● Using either the selection tool or the Select by Attributes dialog box, select a feature (in this 

case, any region e.g. Soroti) from the UGA_adm1.shp layer. 

● From the Main Menu toolbar, click Selection > Select by Locations 

The Select by Locations dialog box appears: 

● Select features from “UGA_towns_2009” data layer, choose Source Layer as UGA_adm1. 

Make sure that Use selected feature box under the source layer is checked. 

● Under Spatial selection method for target layer feature(s) choose “intersect the source layer 

feature” 

● Click OK 
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● Click Selection > Zoom to Selected Features 

● Right click on places > Open Attribute Table 

● Click Selected (at the bottom of the Attribute Table) to display in the table only selected attributes. 

This is how your map should look (of course, depending on the country of your selection): 

 

● Click Clear Selection button and then zoom to full extent 

1.1.22 Joining Tables 

Attribute tables contain predefined fields that hold data on geometry and the object ID. We can also add 

excel table into ArcGIS workspace and view the table. This table can be joined with existing layer or 

converted into a shapefile. 

In this exercise you will be joining the NDVI anomaly mean for February 2019 data to the level 2 

(UGA_adm2) administration boundary polygons. 
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● Add “UGA_adm2.shp” and “Mean_NDVI_anom_February2019.txt” data to ArcMap from this 

location; X:\UG_data\Module1\Baseline_data 

Attribute tables for feature layers are automatically loaded when the layer is added to the map. Tables 

without associated features only show up on the Source tab of the ArcMap table of contents. 

 

Join the attributes of the “Mean_NDVI_anom_February2019” table to the Attribute table of 

“UGA_adm2”. 

● Right-click the layer or table you want to join (UGA_adm2), point to Joins and Relates > click 

Join. 

 

● Click the first drop-down arrow and click Join attributes from a table. 

● Click the second drop-down arrow and click the field name in the layer “NAME_2” on which the 

join will be based. 

● Click the third drop-down arrow to choose the table to join to the layer 

“Mean_NDVI_anom_February2019.txt”. 

● Click the fourth drop-down arrow and click the field in the table on which to base the join 

“NAME_2”. 

● Click OK 



 

 

22 
 

 

 
Open the attribute table of “NAME_2”. The attributes of the table are appended to the layer's attribute 

table.  
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● To sort values in an attribute field right-click the selected field's heading and click Sort 

Ascending or Sort Descending. 

 
 

Which county has the highest mean of NDVI anomaly in February? ___________________ 

 

Which county has the least mean of NDVI anomaly in February? ____________________ 

 

NOTE: You may want to remove the current join from “UGA_adm2” to do so, here is the procedure; 

● Right-click the layer containing a join you want to remove and point to Joins and Relates. 

● Point to Remove Join(s) and click the join you want to remove 

“Mean_NDVI_anom_February2019.txt”. 

 

Basic Geoprocessing and Spatial Analysis 

Rational: The main rationale for using geoprocessing tools and spatial analysis is to try to answer some 

spatial questions which are necessary to get more information out of your data to make an informed 

decisions. 

Geoprocessing: refers to an activity or set of activities in GIS used to manipulate spatial data. A typical 

geoprocessing operation takes an input dataset, performs an operation on that dataset, and returns the 

result of the operation as an output dataset. All data preparation and manipulation can be called 

Geoprocessing. We will see some of the most important tools under this topic which really helps you 

answer spatial questions. There are hundreds of tools in ArcGIS to handle the various chores of a day to 

day GIS activities. 
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1.1.23 Spatial Analysis 

The rationale for spatial analysis science is to understand the spatial distribution, variation, interaction 

and relationships of features or phenomena. According to Carleton College definition spatial analysis is 

a set of techniques for analyzing spatial data. The results of the spatial analysis are dependent on the 

locations of the objects being analyzed. Software that implements spatial analysis techniques requires 

access to both the locations of objects and their attributes. The other description is from ESRI “Spatial 

analysis is how we understand our world—mapping where things are, how they relate, what it all means, 

and what actions to take. From the computational analysis of geographic patterns to finding optimum 

routes, site selection, and advanced predictive modeling, spatial analysis is at the very heart of 

Geographic Information System (GIS) technology.” 

 
 

The goal of the spatial analysis is to answer spatial questions which might be related to location, pattern, 

change, scenarios and others. GIS software’s are designed to provide a state of the art tools to process 

data and answer such complex space based questions. 

There are hundreds of tools under the QGIS toolbox to help you carry out spatial analysis, however, it is 

very important to first design a methodology or a model which needs to be supported with scientific 

methods to reach at a conclusion. 

 STEP (4) 

1.1.24 Buffer Analysis 

Buffer analysis is one of the most important Geoprocessing tools that help to identify proximity of places 

from a reference layer. For instance, if you wish to identify road networks within 3km of water points you 

can easily identify them. Let’s create a buffer of 300m from a Major rivers and see how far people should 

build of farm from the river. 

● Open ArcMap and add the layer for Rivers from X:\UG_data\Module1\Baseline_data folder  

● Click on Geoprocessing from the Menu Bar > then Click on Buffer 
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● Under Input Features select “Rivers”  

● Save Output Feature Class as River_Buffer.shp X:\UG_data\Module1\Output 

● Linear Unit should be 300 meters > Click OK 

● Zoom in to one river line to see the buffer area of 300m.  

 
 

What are the different areas this can be used? ____________________________________ 

 

What if we want different buffer distance like 1km, 5km, and 10km to show from most to least 

areas at risk of flood hazard? 
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1.1.25 Multiple Ring Buffer  

Multiple Ring Buffer allows us to create multiple buffers at 

specified distances around the input features. The different levels 

of buffer distances can be used to define different elements at 

risk. 

1. Click on Search tool and type Multiple Ring Buffer.   

2. Click on the Multiple Ring Buffer (Analysis) tool. 

3. Under Input Select Rivers 

4. Save the Output as “River_Mult_Buffer.shp” to the path 

X:\UG_data\Module1\Output 

5. Under Distances give the following three levels, 1, 5, and 10 km. Type each and click on the 

plus button (+).  

6. Change the Buffer Unit option to Kilometers > Click OK 

7. Now Zoom in to River_Mult_Buffer and see the different levels of Buffer distances.  
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1.1.26 Intersect  

This is an important geoprocessing tool to find the intersection between two or more layers. It has a 

practical application, for instance if you wish to calculate the Primary road coverage across the different 

regions of Ugandsa you can intersect primary roads with admin2 layer. 

 

Steps  

● Open ArcMap and add roads layer from X:\UG_data\Module1\Baseline_data and UGA_Adm2 

from X:\UG_data\Module1\Admin folders respectively 

● Now go to Windows in the main menu and click on Search. Key in Intersect  and search and 

then open the Intersect (analysis) tool  

● Now give roads layer and UGA_Adm2 as intersect features 

● Save the Output feature class to X:\UG_data\Module1\Output folder with the name 

Roads_Admin2.shp and click Ok. 

● Now you can open the attribute table of the Roads_Admin2.shp to see that the district names 

are attached to the roads table. This means that you can also calculate the distance of roads in 

each of the region. You can classify the Roads_Admin2.shp to see the road map in each region. 

1.1.27 Merge 

Merge is another important tool for combining two or more layers of same feature types. This tool provide 

an opportunity to compile data of similar nature. Take for instance, you can merge UGA_towns_2009 

and UGA_north_uganda_health_facilitiy_jan_2011 two point layers, which can be used for certain 

purposes.  

 

Let’s merge the UGA_towns_2009 and UGA_north_uganda_health_facilitiy_jan_2011 layers in Uganda 

for further analysis. 

● Add the UGA_towns_2009 and UGA_north_uganda_health_facilitiy_jan_2011 layers from 

X:\UG_data\Module1\Baseline_data  

● Search for a tool Merge and open. Set the UGA_towns_2009 and 

UGA_north_uganda_health_facilitiy_jan_2011  as inputs layers  

● Save the Output feature class to X:\UG_data\Module1\Output folder with the name 

Towns_Health_facilities.shp and click OK 

● If you open the layer, you will notice that the two layers and their attribute tables are combined. 
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1.1.28 Saving a Map 

After you finish working on a map, you can save it and exit ArcMap. ArcMap saves your map as a project 

document (.mxd). The Home folder available in the Catalog window is used by default in ArcMap to save 

results, store new datasets, and to access file-based information. In addition, each map document has a 

default geodatabase, which is the home location for the spatial content of your map. This location is used 

for adding datasets and for saving resulting datasets created by various editing and geoprocessing 

operations. 

If you haven't saved the map project before and you want to save it into a desired folder location: 

● Click File > Save As. 

● Enter the name “Module1_Intro_ArcMap.mxd”  and save it on: X:\UG_data\Module1\Output  
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 STEP (5) 

Open GIS data Sources 

In the aftermath of a disaster it is very important to collect and review disaster related information from 

media reports, OCHA situation reports, reports from government and local authorities. This would enable 

you to get an understanding about the type and magnitude of the disaster event which is very useful 

before doing any kind of geospatial analysis. When a first review of available disaster- related information 

is completed, you can start searching and gathering relevant geo-data (i.e. pre and post disaster satellite 

imagery and GIS baseline data) to be used for GIS analysis and mapping. 

1.1.29 Baseline Geospatial Data for Disaster Risk Assessment 

This section presents a list of free and commercial spatial available for download. Explore and download 

some GIS and EO data by browsing different geospatial data portals, which provide access to useful data 

sets for emergency response mapping. 

Web Portal Web Link Data Description Data Type 

ICPAC-

Geoportal 

http://geoportal.icpac.net/ Free regional data Vector/Raster 

ArcGIS Online http://www.esri.com/software/arcgis/a

rcgisonline 

 

Free online imagery, 

relief, topography, road 

networks 

Web map, not 

editable, only 

visual 

Giovanni http://giovanni.gsfc.nasa.gov/giovann

i/ 

Free Precipitation data 

(TRMM, GPM) 

TIFF 

MODIS Rapid 

Response 

System 

http://earthdata.nasa.gov/lance/rapid-

response 

Free imagery from 

MODIS sensor 

Multiband 

raster 

http://www.esri.com/software/arcgis/arcgisonline
http://www.esri.com/software/arcgis/arcgisonline
http://giovanni.gsfc.nasa.gov/giovanni/
http://giovanni.gsfc.nasa.gov/giovanni/
http://earthdata.nasa.gov/lance/rapid-response
http://earthdata.nasa.gov/lance/rapid-response
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Digital Globe http://www.digitalglobe.com Commercial satellite 

very high resolution 

imagery 

Preview 

imagery can be 

downloaded 

USGS 

earthexplorer 

http://earthexplorer.usgs.gov 

 

Free Landsat, ASTER, 

SRTM, MODIS 

Raster 

Open Street 

Map OSM 

http://extract.bbbike.org/ 

 

Free Baseline data Vector 

Humanitarian 

Data Exchange 

https://data.hdx.rwlabs.org/ 

 

Free Baseline data Vector/Raster 

Sentinel 

Scientific Hub 

https://scihub.copernicus.eu/dhus 

 

Free RADAR and high 

resolution OPTICAL 

data 

Raster 

WorldPop http://www.worldpop.org.uk/ Free Population data Raster 

 

 

 

 

 

 

http://www.digitalglobe.com/
http://earthexplorer.usgs.gov/
http://extract.bbbike.org/
https://data.hdx.rwlabs.org/
https://scihub.copernicus.eu/dhus
http://www.worldpop.org.uk/
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MODULE: 2 
INTRODUCTION TO EARTH OBSERVATION/REMOTE 

SENSING 
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2.1 Theories and Concepts on Earth Observation/Remote Sensing  

2.1.1 Introduction 

Remote sensing is a valuable data source to obtain information about the surface of the Earth. Several 

platforms have been historically used to collect data, starting from kites to balloons, airplanes, satellites 

and very recently, unmanned aerial vehicles. The applications of remotely sensed data are extremely 

broad, and it is increasing exponentially due to recent improvements in data resolution and availability.  

In this module, we will explore the basics of remote sensing and how ArcMap tools could be used to 

perform basic image pre-processing such us Composing, Mosaicing, and Clipping. 

 

Learning Objectives  

By going through this exercise you will be familiarized with basic image pre-processing involved in 

remote sensing and you will be able to: 

➢ Understand the concept of Remote Sensing. 

➢ Download Sentinel-2 data from the Web. 

➢ Load satellite imageries into ArcMap. 

➢ Perform band combinations (Composing). 

➢ Mosaicing for different screens. 

➢ Clip raster data with using AOI. 

➢ Perform unsupervised/supervised image classification  
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GLOSSARY 

Remote sensing is the science of collecting and interpreting information about the environment and 

the surface of the earth from a distance, primarily by sensing radiation that is naturally emitted or 

reflected by the earth's surface or from the atmosphere, or by sensing signals transmitted from a device 

and reflected back to it. 

 

Platform is the structure or vehicle on which the remote sensing instrument (sensor) is mounted. 

Sensor is the instrument that detects and conveys the information that constitutes an image. Sensors 

are of two primary types active and passive. 

Active sensors provide their own source of energy to illuminate the objects they observe. 

Example: Radio Detection and Ranging (RADAR) and Light Detection and Ranging (LiDAR) 

Passive sensors detect sunlight radiation reflected from the earth and thermal radiation in the visible 

and infrared of the electromagnetic spectrum. They measure signals at several spectral bands 

simultaneously, resulting in so-called multispectral images. When an image consists only of one band, 

it is called panchromatic image. 

The electromagnetic (EM) spectrum is the range of all types of EM radiation. Radiation is energy 

that travels and spreads out as it goes – the visible light that comes from a lamp in your house and 

the radio waves that come from a radio station are two types of electromagnetic radiation. 

 

Resolution: Spatial (pixel size), spectral (wavelength interval size and number of intervals or bands), 

temporal (amount of time needed to revisit and acquire data for the exact same location), and 

radiometric (ability to detect differences in brightness). 

Band: Multispectral remote sensors capture image data at specific frequencies across the 

electromagnetic spectrum. When a multispectral sensor captures a scene, all data captured at different 

range of electromagnetic spectrum are saved in different digital raster files. Each of these raster refers 

to a specific band. 

Normalized Difference Vegetation Index (NDVI) is one of the most common indices used to assess 

vegetation from satellite data. It is a unique band combination that takes advantage of the high 

reflectance properties of vegetation in Red and Near Infrared bands (NIR). 
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 STEP (5) 

2.2 Image Pre-processing 

Image Pre-processing is done prior to data analysis, it’s carried out to correct for any distortions. These 

procedures include radiometric correction to correct for uneven sensor response, Geometric correction 

to correct for geometric distortion due to Earth’s rotation or to conform to a specific map projection system 

and Image Georeferencing where Ground Control Points (GCP’s) are used. 

2.2.1 Searching, exploring and downloading sentinel-2 imagery 

From the Earth Explorer https://earthexplorer.usgs.gov/ you can download radar and optical data. For 

first time users, you need to register and create an account. Make sure you select Sentinel-2 satellite or 

Landsat 8 on the data search, specify the cloud cover percentage and define area of interest. 

 

https://earthexplorer.usgs.gov/
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For Sentinel-2 data, the downloaded product contains multiple folders. Within the Granule folder you 

will find all the subsets that conform the whole scene downloaded. Each folder (subset) contains (within 

the IMG_DATA folder) the 13 raster layers (13 spectral bands) for such subset. Layers 4,3,2 and 8 are 

the Red, Green, Blue and Near Infrared(NIR) respectively. 

2.2.2 Compositing, Mosaicing, and Clipping 

Image Composing allows you to combine raster bands to create various RGB band combinations.  

● In ArcMap, navigate to Geoprocessing > ArcToolbox > Data Management Tools > Raster > 

Raster Processing > Composite Bands. 

● Click the browse button and search for the desired input raster bands. 
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Another option is to use the Composite button in the Image Analysis window,  

● Load the different bands in ArcMap in our case bands 2348 > Navigate to Windows > Images 

Analysis 

 

A multi layered true color image is automatically displayed, composite the other image provided using the 

same procedure above. 
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Note: The composite image is added as a temporary layer. To save the output layer as a raster 

dataset, click the export button on the Image Analysis window and specify the output location. 

Image Mosaicing allows you to combine two or more images. 

 

● Navigate to Geoprocessing > ArcToolbox > Data Management Tools > Raster > Raster 

Dataset > Mosaic 

● Click the browse button and load the two images. 

 

 

Image Clipping allows you to clip a smaller area of interest from a bigger Image. 

● Create an Area Of Interest (AOI) by drawing a polygon shapefile, An AOI has been provided for 

you, use it to clip the Image1. 

● Navigate to Geoprocessing > ArcToolbox > Data Management Tools > Raster > Raster 

Processing > Clip 
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To clip the Area Of Interest; go to Arc Tool box> Data Management Tools> Raster> Raster 

Processing> Clip. Output Extent - input the AOI Shapefile. 
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Display the image you have just clipped - Image1_Clip.tif and use it to do both supervised 

and Unsupervised classification. 

 STEP (6) 

2.3 Image Classification 

Image classification refers to extracting information from multiband raster. The resulting raster from image 

classification can be used to create thematic maps. 

2.3.1 Unsupervised Classification  

Unsupervised classification works well when the user doesn’t know how many classes are present in 

the image. The computer uses the spectral signature to determine which class to place the pixel in. 

● Go to Customize > Extensions > Make sure the spatial analyst box is checked. 

● Go to ArcToolbox > Multivariate > Iso Cluster Unsupervised Classification. 

● Place the Image to be classified in the Input Raster Bands. 
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● Output of an unsupervised classification is shown below: 

 

2.3.2 Supervised Classification 

Supervised classification uses the spectral signatures obtained from training samples to classify an 

image. The image interpreter determines the classes and identifies the training samples for different 

land cover types. The process involves 

- Creating training areas 

- Creating signature file 

- Classifying the image 

● Go to Customize > Extensions > Make sure the spatial analyst box is checked.  
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● On the toolbar, make sure the Image Classification is checked. 

● Create training areas of the following classes 

1) Forest 

2) Shrubland 

3) Grassland 

4) Farms 

 

 
Use the draw tool shown here to draw the training sites.  
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Polygons drawn are an example of forest training sites, do the same for all the other land cover classes. 

Once you draw the training sites, open the training sample manager and give sample name and value. 

 

Draw all the other training sites and give class names and values. 
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● Save the training signature as Training Sites.gsg 

 

To Classify the Image, Use Maximum Likelihood on the classification window 

 

● Input Raster Bands -Input the Image you would like to classify Image1_Clip.tif and Input the 

signature file Training_Sites.gsg. 

● Give an output name - Supervised.tif and click ok, an Image with the 4 classes will be 

displayed. 
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Map Layout 

Using the supervised classification you have just created above, make a simple map layout.  

 

Exercise 2.1: Analysis of Elements at Risk 

 

Introduction 

In this session, analysis of the elements at risk within the area of interest will be carried out. 

Learning Objectives 

In this session, the participants will be able to analyse the elements at risk with the area of interest i.e. 

parts of Amuru and Adjumani districts in Uganda.   

● Understand the geographical extent of parts of Amuru and Adjumani districts in Uganda.  

● Understand the elements at risk database given.   

 

Data Input 

The input data used in this module is, 

Description Data path Data Type File Name 

Area of Interest 

Boundary 

\UG_Data\Module2\Elements

_At_Risk\Input\Vector\ 

Vector (polygon) Amuru_Adjumani_AOI.shp 

Road Network \UG_Data\Module2\Elements

_At_Risk\Input\Vector\ 

Vector (polyline) Roads_AOI.shp 

Settlements \UG_Dataa\Module2\Elemen

ts_At_Risk\Input\Vector\ 

Vector (point) Towns_AOI.shp 

Land use \UG_Data\Module2\Elements

_At_Risk\Input\Vector\ 

Vector (polygon) Lulc_AOI.shp 

Population (Grid) 

data 

\UG_Data\Module2\Elements

_At_Risk\Input\Raster\ 

Raster Worldpop_AOI.tif 

Output 
Output expected in this session is, 

● Types of Roads and their length within the Area of Interest 

● Land use categories and their area in sq.km within the Area of Interest. 

● Number of Settlements within the Area of Interest. 

● Number of Population within the Area of Interest. 

Understanding the elements at risk 

Open the Elements_At_Risk.mxd in ARC GIS software available at  

 

X:\UG_Data\Modue_2\Elements_At_Risk|Workspace 

 

Hint: Use Attribute Table tool to answer.  
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● How many Road types are exiting within the Area of Interest, what are they and what is the total 

length of each road category within the Area of Interest? 

  

________________________________________________________________________________ 

 

________________________________________________________________________________ 

 

● How many settlements exists within the Area of Interest?  

  

________________________________________________________________________________ 

  

________________________________________________________________________________ 

  

● How many land use categories exist within the Area of Interest and what are they and the area of 

each land use category? 

  

________________________________________________________________________________ 

  

________________________________________________________________________________ 

  

● What is the range of population within the Area of Interest and total population within the Area of 

Interest? 

  

________________________________________________________________________________ 

  

________________________________________________________________________________ 

 

Exercise 2.2 Selection, Download and Pre-Process Sentinel-1 data 

  

Introduction: 

Floods are one of the most, widespread, frequent, and recurring natural disasters. Floods are a 

consequence of the increasing frequency of heavy rains, changes in upstream land-use, and a 

continuously increasing concentration of population and assets in the flood plains. Floods can occur 

anywhere because of heavy rain and can be of different intensities—from small flash floods to sheets of 

water engulfing huge areas of land, causing destruction either way. 

  

Over the years, advances have been seen in remote sensing measurements, which are gradually 

replacing or compensating in situ measurements. Aerial reconnaissance has been effective for 

determining the spatial extent of river flooding in detail for relatively small areas. 

  

Even though the use of image data from optical satellite sensors (like Pan, LISS, etc.) in the visible or 

infrared portion of the spectrum is very useful for studying land features, their usefulness is limited during 

the rainy season due to cloud cover being visible on the image. On the other hand, the microwave portion 

of the spectrum gives cloudless images even during the monsoon season. Microwave remote sensing 

data can penetrate clouds, which is important for monitoring flood events because they commonly occur 

during periods of extended rainfall or cyclonic storms. However, for most remote sensing solutions, the 

revisit frequency (i.e., the time between two measurements in the same place) is too low for monitoring 
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purposes, or the spatial coverage is limited. Both active and passive microwave data have been 

extensively explored for flood monitoring. 

  

In this exercise, you will be exploring the freely available microwave satellite data from the first of the 

Copernicus Programme satellite constellation conducted by the European Space Agency, which consists 

of two satellites, Sentinel-1A and Sentinel-1B that carry a C-band synthetic-aperture radar instrument 

which provides a collection of data in all-weather, day or night. 

  

Learning Objectives: 

The objective of this module is to familiarize with Sentinel-1 satellite data sets for flood studies. After 

completing this session, the course participants will be able to download the Sentinel-1 satellite data of 

flood affected area and will learn how to use it in the next sessions. 

● Identify an area of interest (AOI) which was flood affected recently () 

● Search the Sentinel-1 satellite data coverage in the AOI. 

● Select and download the Sentinel-1 satellite data for the AOI. 

 Data Input: 

Area of Interest (to be selected by the participants) Example: parts of Amuru and Adjumani districts 

in Uganda were flooded on 23 August 2017.   

 

Output: 

Sentinel-1 satellite data covering the AOI 

  

Accessing the Sentinel-1 satellite data 

  

Create a User Account 

  

Go to Copernicus Open Access Hub (https://scihub.copernicus.eu/dhus) . In the top-right of the web 

map, click the SIGN UP  button. Insert valid entries for your name, email and location. Click register. 

Validate your email and Login using the username and password. 

With a few clicks of the mouse, you will gain access to ESA’s Sentinel data. 

https://scihub.copernicus.eu/dhus
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Select Your Area of Interest (AOI) 

Where is your study area? 

  

Answer: 

Using the SEARCH CRITERIA  text box in the top-left, type in your area of interest. 

Example: Type ‘Uganda’ and Click search option.   

Using the Map Layer option (on right side) you can change the background map / image. Use PAN option 

(at the bottom of the screen) to PAN to the area of interest and zoom into the ‘parts of Amuru and 

Adjumani districts in Uganda in Northern part of Uganda and use BOX option draw a rectangle in the 

area of interest. (You are free to select any other area of interest, if you know which area is flooded?) 

 

 
Click on the top left corner of the search window as shown for the advanced options.   
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Now select the below given options of selecting suitable data. 

  

Sort by: Ingestion Date 

Order By: Descending 

Sensing Period: Select 23 August 2017 to 23 August 2017 (if your AOI is different, please select suitable 

date) 

  

What is Sensing Period? 

  

____________________________________________________________________________ 

  

Satellite Platform: leave it blank (it will take both S1A_ or S1B_  satellites) 

Product Type: GRD 

Sensor Mode: IW 

  

What are these parameters? Explore the Sentinel Product Catalogue at 

https://sentinel.esa.int/web/sentinel/missions/sentinel-1/data-products 

  

Click Search option. 

  

From here your search will yield results for all the Sentinel satellite data available Sentinel-1 (Synthetic 

Aperture Radar C-Band) swaths are depicted in red. 

See the product thumbnails for more details of the search results. 

 

 
 

Search Results contain how many products? 

  

_________________________________________________________________________ 

  

https://sentinel.esa.int/web/sentinel/missions/sentinel-1/data-products
https://sentinel.esa.int/web/sentinel/missions/sentinel-1/data-products
https://gisgeography.com/synthetic-aperture-radar-examples/
https://gisgeography.com/synthetic-aperture-radar-examples/


 

 

49 
 

 

Download SENTINEL-1 SAR Data 

As we are working with large data sets, you will have to be patient with download speeds. It’s easy for 

the server to timeout during the download. 

Select the product you want to download. S1A is Sentinel-1A. 

Go through the search results and select this Sentinel-1A data (parts of Amuru and Adjumani 

districts in Uganda).   

S1A_IW_GRDH_1SDV_20170823T033508_20170823T033535_018045_01E4BF_8088.ZIP 

 

Why this data is selected? 

  

_________________________________________________________________________ 

  

Before downloading, click on the icon ‘eye’ in the selected data window to preview the data, as shown. 

 

 
 

What additional information you can get from this preview window? 

  

_________________________________________________________________________ 

  

_________________________________________________________________________ 

  

Click on Download URL next to the product thumbnail or Download Arrow @bottom right corner to 

download the data. Since it will take time to download, we have downloaded the data and provided for 

use in this session. 
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SENTINEL – 1 SAR DATA PRE-PROCESSING 
 ·         Download SENTINEL Toolbox 

  

Download and install the latest ESA-SNAP-SENTINEL Toolbox (Open source software from ESA) 

Link: http://step.esa.int/main/download/ 

The webpage will look like this. 

 

 
Select suitable Windows / Mac version suitable for your laptop and download the software. 

 
 

Install the downloaded SNAP software for using the downloaded Sentinel-1A satellite data, downloaded 

previously. 

 Displaying, exploring and analyzing crisis satellite data for flood water extraction 

 ORTHORECTIFICATION 

In this section you are going to perform the main image processing operation required prior to analysing 

an image. The most appropriate software to process Sentinel-1 imagery is the Open source software 

http://step.esa.int/main/download/
http://step.esa.int/main/download/
http://step.esa.int/main/download/
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from the European Space Agency (ESA) called Sentinel Application Platform (SNAP) TOOLBOX. This 

platform reunites all Sentinel Toolboxes in order to offer the most complex platform for this mission. The 

basic functions include: opening a product, exploring the product components such as bands, masks and 

tie point grids. Navigation tools and pixel information functionality also represent some of the basic 

capabilities. 

To Open SNAP toolbox, Double Click the SNAP software shortcut on your desktop, which will be as 

given below.  

 
 

Import the downloaded SENTINEL-1A image 

S1A_IW_GRDH_1SDV_20170823T033508_20170823T033535_018045_01E4BF_8088.ZIP 

Please note that SNAP reads automatically .zip files (no need to unzip): 

The steps given below are only for your understanding and future use on your own dataset. 

Final processed data is given to you for extracting flood extent. 

Import the Sentinel-1A data downloaded using File – Import – SAR Sensors – SENTINEL-1 as shown 

below. 
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Optional Step: Radar > Radiometric > Calibrate 

The most important step after importing the data is to orthorectify the image (not optional!) 

 

There are five steps in the Geometric SAR-Simulation Terrain Correction – it is highly recommended to 

do as little modification as possible, to make the process faster: 

○ 1-Read:Choose “Any Format” or “Sentinel-1”under Data Format 

○ 2-SAR-Simulation: Select “Amplitude VV” 
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○ 3-GCP-Selection: GCPs can be reduced to a desired value if it fails to find enough points (default 

value is 2000). It is advised to leave it as default 

GCPs or the Ground Control Points are defined as the points on the surface of the earth of known 

location that could be used to geo-reference remotely sensed data 

○ 4-SARSim-Terrain-Correction: Recommended to leave it as default 

○ 5-Write. Give a proper Name and Save as: “Geotiff-BigTIFF” and navigate to the output folder 

and click Run 

 

It is the processed image obtained after the ortho-rectification (terrain correction) and the speckle filtering, 

steps are given here, only for your understanding and future use. 

 In most RADAR products, one of the must do corrections is to remove speckles (salt and pepper 

effect). Again, this step will take few minutes but it is highly recommended. Go to Radar > Speckle 

Filtering > Single Product Speckle Filter 

 

 

In the I/O Parameters tab: 
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○ Select as Source the output image of the SAR-Simulation Terrain Correction 

○ Give a proper Name and Save as: “Geotiff-BigTIFF” and navigate to the output folder 

 

In the Processing Parameters tab : 

○ select as Source BandsSigma0_VV 

○ choose Gamma Map Filter, the Filter Size X: 3 and Y:3  can be used. Feel free to 

compare with 5x5 and 7x7 as Filter Size. 

·         Click Run and be patient. 

 
Given that the process may take some time to be completed, as already stated previously, you can find 

the processed image. 

Flood_23082017.tif 

 is provided at   X:\UG_Data\Module_2\Sentinel-1\Input\ 
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Opening ArcMap and exploring crisis satellite data 

Once the image has been processed, before quantitatively analyzing the data, it is important to do a 

visual interpretation of the input data available. 

● Open the existing ArcMap project (workspace) “Flood_Hazard_Analysis.mxd” stored on: 

X:\UG_Data\Module2\Sentinel_1\Workspace 

  

In the ToC,make sure that 

Flood_23082017.tif 

 is turned on. 

● For your convenience, a smaller tile is provided for this exercise. 

● From the ToC,right click on AOI >Zoom to layer 

What is the coordinate system of the image? 

-------------------------------------------------------------------------------------------------------------------- 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

56 
 

 

 

 



 

 

57 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

MODULE 3:  
HAZARD, VULNERABILITY AND RISK ASSESSMENT 
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3.1 Introduction to Disaster Risk Management (DRM) 

Learning objectives 

By the end of this module you will be able to: 

▪ Elaborate basic terminologies and concepts in DRM together with Global and Continental DRM 

frameworks 

▪ Demonstrate how to undertake hazard assessment and derive some of the indicators and 

thresholds on drought and flood hazards 

▪ Grasp methods used to produce drought and flood hazard vulnerability and risk maps 

3.1.1 Basic Concepts and Terminologies 

The following are some of the common concepts in Disaster Risk Management (DRM) which 

are useful to understand DRM as a process. Some of the following materials are excerpts 

from Asian Disaster Preparedness Center (ADPC). 

1. A disaster occurs when a hazard impacts a vulnerable community causing damage, 
casualties and disruption. 

2. Vulnerability is a set of prevailing or consequential conditions, which adversely affect the 
community’s ability to prevent, mitigate, prepare for and respond to hazardous events. 

3. Capacities are resources, means and strengths, which exist in households and in the 
community and which enable them to cope with, withstand, prepared for, prevent, 
mitigate or quickly recover from a disaster. 

4. Disaster Risk = Hazard x Vulnerability 
Capacity 

5. Disaster risk reduction includes all measures, which reduce disaster-related losses of life, 
property or assets by either reducing the hazard or vulnerability of the elements at risk or 
by increasing the capacity of at risk communities. 

6. DRM is multi sectoral and Multi-hazard by its very nature 

The common definitions given to the main terminologies in DRM are as follows; 

 

 

 

 

 

 

 

 

 

 

 

 

The glass & the water in this example are the hazard – In this example, an unstable glass of water is 

the hazard threatening our laptop on the table. 

The position of the laptop represents the exposure – Exposure in this example is determined by the 

position of the laptop right under the shelf: our laptop is situated in a “hazard prone” area. 

The characteristics of the laptop represent its vulnerability – the laptops is vulnerable to water 

falling from the glass because it is an electronic device that can be heavily damaged by water. If we had 
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a plastic bowl on the table, instead of a laptop, vulnerability levels would be much lower, or even non-

existent. 

Disaster Risk – The combination of hazard, exposure and vulnerability generates a risk of disaster: if 

the glass full of water falls from the shelf, it is likely to spill water on the laptop and, in consequence, 

affect the functioning of the laptop, which is very sensitive to water, being an electronic device. 

DISASTER 

A disaster is a serious disruption on the functioning of a community or a society involving widespread 

human, material, economic or environmental losses and impacts, which exceeds the ability of the affected 

community or society to cope using its own resources (UNISDR, 2009). 

A disaster happens when a hazard impacts on a vulnerable population or community whose capacity is 

inadequate to withstand or cope with its adverse effects, resulting in damages, loss and disruption in 

community/society functioning. An earthquake in an uninhabited desert cannot be considered a disaster, 

no matter how strong the intensities produced. An earthquake is only disastrous when it affects people, 

their property and socio-economic activities. 

HAZARD 

A hazard is a dangerous phenomenon, substance, human activity or condition that may cause loss of life, 

injury or other health impacts, property damage, loss of livelihoods and services, social and economic 

disruption, or environmental damage (UNISDR -2009). 

The hazards of concern to disaster risk reduction as stated in footnote 3 of the Hyogo Framework are, 

“hazards of natural origin and related environmental and technological hazards and risks.” Such hazards 

arise from a variety of geological, meteorological, hydrological, oceanic, biological, and technological 

sources, sometimes acting in combination. In technical settings, hazards are described quantitatively by 

the likely frequency of occurrence of different intensities for different areas, as determined from historical 

data or scientific analysis. (UNISDR, 2009) 

Hazards can be single, sequential or combined in their origin and effects. For example, an earthquake 

causes landslides, which dams a river and then causes flooding. A community may be exposed to multiple 

hazards when there is simultaneous occurrence of different hazards.

VULNERABILITY 

Vulnerability refers to the characteristics and circumstances of a community, system or asset that make 

it susceptible to the damaging effects of a hazard. (UNISDR, 2009) 

Vulnerability is a set of prevailing or consequential conditions that adversely affect people’s ability 

prevent, mitigate, prepare for and respond to hazardous events. These long-term factors, weaknesses or 

constraints affect a household’s or community’s ability (or inability) also to absorb losses after a disaster 

or to recover from the damage. Vulnerabilities precede disasters, contribute to their severity, impede 

disaster response, and may continue to exist long after a disaster has stuck. 

Anderson and Woodrow (1989) categorize vulnerabilities into three areas, namely: 

1) Physical/Material Vulnerability: 

For example, poor people who have few physical/material resources usually suffer more from disasters 

than rich people. People who are poor often live on marginal lands; they don’t have any savings or 

insurance; they are in poor health. These factors make them more vulnerable to disasters and means 

that they have harder time surviving and recovering from a calamity than people who are better off 
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economically. 

2) Social/Organizational: 

Experience shows that people who have been marginalized in social, economic or political terms are 

vulnerable to suffering from disasters whereas groups that are well organized and in which there is a high 

commitment to each other suffer less when catastrophe strikes. Weakness in social and organizational 

areas may also cause disasters. For example, deep divisions can lead to conflict and war. Conflict of 

resources due to poverty can also lead to violence. The second area of vulnerability then, is the 

social/organizational and economic realm. 

3) Attitudinal/Motivational Vulnerability: 

Experience also shows that people who have low confidence in their ability to affect change or who have 

“lost heart” and feel defeated by events they cannot control, are harder hit by disasters than those who 

have a sense of their ability to bring about the changes they desire. Thus, the third area of vulnerability 

is the attitudinal and motivational realm. 

CAPACITY 

Capacity refers to the combination of all the strengths, attributes and resources available within a 

community, society or organization that can be used to achieve agreed goals. 

Capacity may include infrastructure and physical means, institutions, societal coping abilities, as well as 

human knowledge, skills and collective attributes such as social relationships, leadership and 

management. Capacity may also be described as capability. Capacity assessment is a term for the 

process by which the capacity of a group is reviewed against desired goals, and the capacity gaps are 

identified for further action (UNISDR, 2009). 

Capacity (in contract to Vulnerability) has been included in disaster management initially as a guide for 

both international and local agencies who work with vulnerable communities to link disasters to 

development even in emergency situations disaster survivors have capacities. They are not helpless 

victims but have coping mechanisms on which to build on for emergency response and recovery. As the 

developmental and risk reduction paradigms in disaster management emerged, for many vulnerable 

groups, the viable track to reduce vulnerabilities has been by increasing their social/organizational 

capacities. 

Capacities are resources, means and strengths, which exist in households and communities and which 

enable them to cope with, withstand, prepare for, prevent, mitigate, or quickly recover from a disaster. 

People’s capacity can also be categorized in the same categories as was done with vulnerabilities in the 

previous section. 

1) Physical/Material Capacity: 

Even the very people whose houses have been destroyed by a typhoon or whose crops have been 

destroyed by floods can salvage things from their homes and from their farms. Sometimes they have 

food in storage or crops that can be recovered from the fields or farm implements for planting again. 

Some family members have skills, which enable them to find employment if they migrate, either 

temporarily or permanently. 

2) Social/Organizational Capacity: 

In most disasters, people suffer their greatest losses in the physical and material realm. Rich people have 

the capacity to recover soon because of their wealth. In fact, they are seldom hit by disasters because 

they live in safe areas and their houses are built with stronger materials. However, even when everything 
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physical is destroyed, people still have their skills and knowledge; they have family and community 

organization. They have leaders and systems for making decisions. They have tribal loyalties or church 

affiliations. They have capacities in the social and organizational realm. 

3) Attitudinal/Motivational Capacity: 

People also have positive attitudes and strong motivations such as the will to survive, love and concern 

for each other, bravery and willingness to help each other. These are also important capacities, and form 

the basis for development just as much as the physical resources that people have. Coping 

mechanisms/strategies are generally considered capacities for survival. 

DISASTER RISK REDUCTION (DRR) 

Disaster Risk Reduction is the concept and practice of reducing disaster risks through systematic efforts 

to analyze and manage the causal factors of disasters, including through reduced exposure to hazards, 

lessened vulnerability of people and property, wise management of land and the environment, and 

improved preparedness for adverse events (UNISDR, 2009). 

DISASTER RISK MANAGEMENT (DRM) 

Disaster Risk Management is the systematic process of using administrative directives, organizations, 

and operational skills and capacities to implement strategies, policies and improved coping capacities in 

order to lessen the adverse impacts of hazards and the possibility of disaster (UNISDR, 2009). 

PREVENTION 

Prevention refers to the outright avoidance of adverse impacts of hazards and related disasters (ISDR, 

2009). 

MITIGATION 

Mitigation refers to lessening or limiting the adverse impacts of hazards and related disasters (ISDR, 

2009). Mitigation can broadly be divided into structural mitigation and non-structural mitigations. 

Structural mitigation includes engineering measures such as retrofitting, retaining walls, flood barriers 

etc. Non- structural measures include land-use zoning, building codes, construction policies and bylaws, 

training on structural mitigations etc. 

PREPAREDNESS 

Preparedness refers to the knowledge and capacities developed by governments, professional response 

and recovery organizations, communities and individuals to effectively anticipate, respond to, and recover 

from, the impacts of likely, imminent or current hazard events or conditions (UNISDR, 2009). 

EMERGENCY MANAGEMENT 

Emergency management is the organization and management of resources and responsibilities for 

addressing all aspects of emergencies, in particular preparedness, response and initial recovery steps 

(ISDR, 2009). 

RESPONSE 

Response is the provision of emergency services and public assistance during or immediately after a 
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disaster in order to save lives, reduce health impacts, ensure public safety and meet the basic 

subsistence needs of the people affected (ISDR, 2009). 

RECOVERY 

Recovery is the restoration and improvement where appropriate, of facilities, livelihoods and living 

conditions of disaster-affected communities, including efforts to reduce disaster risk factors (ISDR, 2009). 

DISASTER RESILIENCE 

Disaster resilience is the capacity of a system, community or society to resist or to change in order to 

obtain an acceptable level in functioning and structure. This is determined by the degree to which the 

social system is capable of organizing itself, and the ability to increase its capacity for learning and 

adaptation, including the capacity to recover from a disaster. 

3.1.2 Disaster Risk Management Process 

Disaster Risk Management, as a process can be seen from different points of views; some of these 

include processes from the hazard, disaster governance, and disaster cycle points of views. According 

to a training manual prepared by ADPC, DRM process in general requires the following: 

● Establish the context and build partnerships and rapport based on the mandates and context; 

● Identify the hazards (Hazard Assessment); 

● Determine  the  elements  at  risk  (people  and  health,  property,  livelihoods,  

Community structures, critical facilities, environment etc.) (Exposure Assessment); 

● Determine conditions and factors of vulnerability. Why can the elements at risk be 

damaged? (physical, economic, social, motivational reasons) (Vulnerability 

Assessment); 

● Identify existing coping strategies and capacities/resources (material, human, 

institutional/organizational, motivational etc.) (Capacity Assessment); 

● Assess risks (based on the Hazard, Vulnerability and Capacity Assessment); 

● Identify measures or solutions to reduce the vulnerability of the elements at risk. How 

to protect and strengthen the elements at risk and how to reduce the impact of the 

hazard? 

● Prioritize risk reduction measures to undertake: immediate, short-term, medium-term, 

long- term; 

● Implement the risk reduction measures as planned; 

● Monitor and evaluate the programs 

The Disaster Risk Management Cycle takes the form indicated below. 
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3.1.3 Global, Continental and National Frameworks/Platforms on DRR 

a) The Sendai Framework for Disaster Risk Reduction 

The Sendai Framework is a 15-year, voluntary, non-binding agreement which recognizes that the State 

has the primary role to reduce disaster risk but that responsibility should be shared with other 

stakeholders including local government, the private sector and other stakeholders. It aims for the 

following outcome: The substantial reduction of disaster risk and losses in lives, livelihoods and health 

and in the economic, physical, social, cultural and environmental assets of persons, businesses, 

communities and countries. 

The Sendai Framework for Disaster Risk Reduction 2015-2030 (SFDRR) stresses that there has to be a 

broader and a more people-oriented preventive approach to disaster risk. DRR practices needs to be 

multi-hazard and multi-sectoral, inclusive, and accessible in order to be efficient and effective. 

Governments should engage with relevant stakeholders, including women, children and youth, persons 

with disabilities, people living under poverty, migrants, indigenous peoples, volunteers, the community of 

practitioners and older persons in the design and implementation of policies, plans and standards. 

3.1.3.1 Priorities for Action 

Priority 1: Understanding disaster risk 

Disaster risk management should be based on an understanding of disaster risk in all its dimensions of 

vulnerability, capacity, exposure of persons and assets, hazard characteristics and the environment. 

Such knowledge can be used for risk assessment, prevention, mitigation, preparedness and response. 

Priority 2: Strengthening disaster risk governance to manage disaster risk 

Disaster risk governance at the national, regional and global levels is very important for prevention, 

mitigation, preparedness, response, recovery, and rehabilitation. It fosters collaboration and 

partnership. 

Priority 3. Investing in disaster risk reduction for resilience 



 

 

64 
 

 

Disaster risk governance at the national, regional and global levels is very important for prevention, 

mitigation, preparedness, response, recovery, and rehabilitation. It fosters collaboration and 

partnership. 

Priority 4. Enhancing disaster preparedness for effective response and to “Build Back Better” in 

recovery, rehabilitation and reconstruction 

The growth of disaster risk means there is a need to strengthen disaster preparedness for response, take 

action in anticipation of events, and ensure capacities are in place for effective response and recovery at 

all levels. The recovery, rehabilitation and reconstruction phase is a critical opportunity to build back 

better, including through integrating disaster risk reduction into development measures. 

Based on the experiences from the implementation of the HFA, and in order to reach the targets and 

goals, there is a need for focused actions within and across sectors by States, at the local, national, 

regional, and global levels in four priority areas. An enabling international environment and means of 

implementation are needed to stimulate and contribute to developing the knowledge, capacities and 

motivation for disaster risk reduction at all levels, particularly for developing countries. 

3.1.3.2 The Seven Global Targets 

1. Substantially reduce global disaster mortality by 2030, aiming to lower average per 100,000 

global mortality rate in the decade 2020-2030 compared to the period 2005-2015. 

2. Substantially reduce the number of affected people globally by 2030, aiming to lower average 

global figure per 100,000 in the decade 2020 -2030 compared to the period 2005-2015. 

3. Reduce direct disaster economic loss in relation to global gross domestic product (GDP) by 2030. 

4. Substantially reduce disaster damage to critical infrastructure and disruption of basic services, 

among them health and educational facilities, including through developing their resilience by 

2030. 

5. Substantially increase the number of countries with national and local disaster risk reduction 

strategies by 2020. 

6. Substantially enhance international cooperation to developing countries through adequate and 

sustainable support to complement their national actions for implementation of this Framework 

by 2030. 

7. Substantially increase the availability of and access to multi-hazard early warning systems and 

disaster risk information and assessments to the people by 2030. 

The Sendai Framework document is provided for you under X:\UG_data\Module3\DRM reading 

materials folder. 

3.1.3.3 African Programme of Action 

Programme of Action for the Implementation of the Sendai Framework for Disaster Risk Reduction 2015-

2030 in Africa was crafted in line with the Africa Regional Strategy for Disaster Risk Reduction. The 

Program of Action (PoA) details the need to align all DRR activities in the continent of the four priority 

areas of the Sendai Framework. The document explains the role of key stakeholders from the UN to AU 

and national to Sub-national actors in the implementation of the programme. Issues related to resource 

mobilization strategies and monitoring of the progress are all covered. 

The document is provided for your additional reading under DRM reading documents folder. 

National DRR Platforms 

Countries have been striving to put in place functional institutions and DRR strategies, policies, plans and 



 

 

65 
 

 

acts which are all aimed at reducing the negative impacts of disasters and building the resilience capacity 

of their respective communities to Disaster risks. In the region several countries have already developed 

national strategies/policies in DRM and this is a very positive step towards resilience building in the 

region. 

3.2 Hazard, Vulnerability and Risk Assessment  

3.2.1 Introduction to Hazard Assessment 

According to Caribbean handbook on disaster risk information management, Hazard data is generally the 

most difficult to generate. For each hazard type (e.g. Drought, flooding, landslide, etc.) so- called hazard 

scenarios should be defined, which are hazard events with a certain magnitude/intensity/frequency 

relationship (e.g. flood depth maps for 10, 50 and 100 year return periods). Different types of modelling 

approaches are required for the hazard scenario analysis, depending on the hazard type, scale of 

analysis, availability of input data, and availability of models. Generally speaking a separate analysis is 

required to determine the probability of occurrence for a given magnitude of events, followed by an 

analysis of the initiation of the hazard. 

Under this section we are going to work on two scenarios on the main hazards in Uganda namely drought 

and floods.  

3.2.2 Drought Hazard Assessment 

Drought is an insidious natural hazard that results from lower levels of precipitation than what is 

considered normal. When this phenomenon extends over a season or a longer period of time, 

precipitation is insufficient to meet the demands of human activities and the environment. The east African 

region is susceptible to recurrent droughts that immensely devastated lives and livelihoods for millions of 

people in the region. The drought cycle in the region is cyclical and when strike often sustained for more 

than one season which often end up in catastrophic damages both to life and property. The trend in 

number of people affected by drought from 1900 to 2015 is given below (Source: EM-DAT/CRED). 

 

 

The American Meteorological Society (AMS) categorizes drought in to meteorological/climatological, 

agricultural, hydrological and socio-economic drought. Meteorological drought refers to monitoring 

of rainfall conditions and where rainfall is below normal conditions. Meteorological and climatological 
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drought is defined in terms of the magnitude of a precipitation shortfall and the duration of this shortfall 

event. Agricultural drought links the various characteristics of meteorological drought to agricultural 

impacts, focusing on precipitation  

Shortages, differences between actual and potential evapotranspiration, and soil moisture deficits. 

Hydrological droughts are related to the effects of periods of precipitation shortfall on surface or 

subsurface water supply, rather than to precipitation shortfalls directly. Socioeconomic drought is 

associated with the supply and demand of some economic good with elements of meteorological, 

agricultural, and hydrological drought. For monitoring and mapping of drought in the greater horn of Africa 

region meteorological and agricultural drought conditions are considered in this training. 

Meteorological Drought: Monitoring of the meteorological drought can be done in different ways and 

one of the most common ways is the Standard Precipitation Index (SPI). McKee, Doesken and Kleist 

(1993) developed the Standardized Precipitation Index (SPI) for the purpose of defining and monitoring 

drought. The SPI was designed to quantify the precipitation deficit for multiple time scales, and to reflect 

the impact of drought on the availability of different water resources. Soil moisture conditions respond to 

precipitation anomalies on a relatively short time scale, while groundwater, stream flow and reservoir 

storage reflect longer-term precipitation anomalies. Akinremi, McGinn and Barr (1996) state that the 

spatial and temporal dimensions of drought create problems in generating a drought index because not 

only must an anomaly be normalized with respect to location, but the anomaly must also be normalized 

in time if it is to produce a meaningful estimate of drought; the SPI accomplishes both. It also provides 

spatial and temporal drought vulnerabilities from the point of rainfall scarcity. 

For you to make meaning to your SPI data there need to set a standard intervals as proposed by the 

developers. For now let’s set it to 9 classes as follows;  

 

                                 
A regionally blended (observed rainfall with Chirps satellite data) at 5km resolution is used to produce 

seasonal SPI for 1984, 2009, 2011 and 2015. One distinct seasons are used in this analysis for the region 

and these are March to May (MAM), June to August (JJA) and September to December (SOND). The 

MAM is the main rainfall season for GHA countries in the equatorial and some parts in the  Southern 

sectors. JJAS is the main rainfall season for countries in the northern sector. A sample map of SPI at 

seasonal scale for the Greater Horn of Africa is given below:  
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NOTE: The weakness of SPI is over estimation in dry and desert areas and thus careful analysis          

             is advised.   

 

A sample SPI for Uganda for April to October 20098 is given below.  

 

 



 

 

68 
 

 

In drought hazard assessment we are going to use two indicators of drought severity, namely the 

rainfall anomaly as calculated through SPI and the Vegetation Anomaly as calculated through VCI and 

VHI. 

3.2.2.1 SPI based drought hazard assessment 

Standardized Precipitation Index (SPI) can be calculated as a function of the difference between current 

rainfall condition and Long Term Average (LTA) and normalized by standard deviation of the rainfall for 

the years under consideration. World Meteorological Organization (WMO) recommends to use data from 

1981-2010 to calculate long term average.  

 STEPS (8): Working with SPI  

For this exercise SPI data layers for Uganda are generated based on the combined 

rainfall seasons from April to October. Please open these layers by following the steps 

below;   

1) Open ArcMap and add the following layers from X:\UG_data\Module3\Drought\SPI folder  

▪ SPI_AMJJASO_2008.tif 

▪ SPI_AMJJASO_2009.tif 

▪ SPI_AMJJASO_2016.tif 

The black and white images has got values and the symbology can be set manually or imported from 

the existing *.lyr file. For this exercise we will import a symbology.  

2) Double click on SPI_AMJJASO_2008.tif and go to symbology and under show click 

classified.  

3) Now click on import and go to X:\UG_data\Module3\Drought\SPI  folder and select 

SPI_symbology.lyr file 

 

4) Click Ok and now your map view should look something similar to this.  
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5) Follow similar steps to change the symbology for 2009, and 2016 SPI data layers.  
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STEPS (9):   

Calculate Zonal Statistics to produce seasonal meteorological drought hazard map for Admin 

Level 3 of Uganda  

1. Add the UGA_Adm3 layer from X:\UG_data\Module 1\Admin 

2. Go to the main menu in ArcMap Windows >> Search  now type  Zonal Statistics and click on 

Zonal Statistics as a Table  

 

2. Set UGA_adm3 as input raster or feature zone data and NAME 3 as zone field. 

3. Select SPI_AMJJASO_2008.tif file as input value raster and save the output 

table under X:\UG_data\Module3\Output folder by the name Zonal 

StatisticsSPI_2008.dbf.  

4. Select MEAN as statistics type and click Ok  

Once the completed you should be able to see table added to your table of content. You can 

open the table under the values field, you can see which district has the lowest mean SPI 

value.   

If you wish to produce the drought severity map based on the rainfall anomaly as measured 

by the SPI you can follow these steps; 

Now we are going to join the two tables UGA_adm3 and Zonal statistics_SPI2008 

using the common field “NAME 3” which is Zone 

5. Right click on UGA_adm3 layer and click on Join and relate >> Join  

6. Select UGA_adm3 in the first drop down field and Zonal statistics table in the 

second and NAME 3 under the third dropdown  

7. Click Ok and you can open attribute table of UGA_adm3 and you find that the two tables 
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are joined. Now we are ready to produce drought severity map of districts based on the SPI 

values. 

8. To save the merged tables as one shapefile you need to right click on UGA_adm3 and 

export data. Save it under X:\UG_data\Module3\Output with the file name 

Drought_hazard_severity.shp. Your new map will be added automatically to the table of 

content.  

9. Let’s produce a drought hazard severity map based on the mean SPI with the 

following range. 

 

 
 

10. Double click on the Drought_hazard_severity.shp layer and go to symbology  

11. Go to Quantities and graduated colors. Now choose MEAN as value field and set the 

number of classes to 5.  

12. Click on Class and set the above range and choose a color (Green to dark red) and Click 

Ok  

Now you should get a map something similar to this.     
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Downloading SPI Data 

Standardized Precipitation Index (SPI) can be obtained from ICPAC Data library & Maproom 

(http://digilib.icpac.net/). Step by Step on how to access the data is shown below: 

● Open this link (http://digilib.icpac.net/) and click on Data by Source. 

 

● Click on ICPAC>>CHIRPS-BLENDED>>monthly>> 

http://digilib.icpac.net/
http://digilib.icpac.net/
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● Change Time, Longitude and Latitude as shown below  

● Then Restrict Ranges > Stop Selecting 
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● Click on Data Flies > then Click on GeoTIFF Image as shown below  

● Once you are sure of the month, Click on e.g. 200908 GeoTiff for GIS 

● Download all the four months to make a season. 
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3.2.2.2  Vegetation anomaly based drought hazard assessment 

Vegetation Condition Monitoring is an important activity and can be done in many different ways. The 
Vegetation Health Index (VHI) represents overall vegetation health and it is a combination of Vegetation 
Condition Index (VCI) and temperature condition index (TCI). While VCI indicates the short-term weather-
related NDVI fluctuations from the long-term mean, the TCI shows the relative change in thermal condition 
of brightness temperature (NOAA Star). 

Compared to ground-based and NDVI-based (two-channel algorithm) detection systems, this new 
method provides earlier drought warnings. It also makes it possible to estimate areas under droughts of 
different severity, and to diagnose the potential for drought development prior to the actual start of drought 
conditions. One of the important advantages of this method is that it makes use of a combination of the 
normalized difference vegetation index (NDVI), normally used alone, and the 10.3-11.3-um thermal 
channel. Assessment of temperature conditions permits one to identify subtle changes in vegetation 
health because the effect of drought is more dramatic if a shortage of moisture is accompanied by 
excessive temperatures. This method was validated in all major agricultural countries around the world. 
(Kogan 2002) 

The VCI and TCI were useful to assess the spatial characteristics, the duration and severity of drought, 
and were in a good agreement with the precipitation patterns. (Ghosh 2007). NOAA STAR website stated 
that the VHI reflects indirectly a combination of chlorophyll and moisture content in the vegetation health 
and also changes in thermal conditions at the surface. This new approach combines the visible, near 
infrared, and thermal radiances in a numerical index characterizing vegetation health. This approach is 
extremely useful in detecting and monitoring such complex and difficult-to-identify phenomenon as 
drought. The VH values below 40 are used for identifying vegetation stress which is an indirect drought 
indicator. The VH is very useful for early drought detection, assessing drought area coverage, duration, 
and intensity, and for monitoring drought impacts on vegetation and agricultural crops. Vegetation 
condition index (VCI). VCI was first suggested by Kogan (1995, 1997). It shows how close the NDVI of 
the current month is to the minimum NDVI calculated from the long-term record.  



 

 

76 
 

 

 

Where, NDVImax and NDVImin are calculated from the long-term record (e.g., 18 years) for that month 
(or week) and j is the index of the current month (week).  

For compositing the weekly VHI values a maximum of the season is calculated and the following map 
presents the results for the three seasons from 2009 to 2016 in the atlas map of IGAD/ICPAC. For 
compositing the weekly VHI values a maximum of the season is calculated and the following map 
[presents the results for the three seasons from 2009 to 2016.  
 

To generate the agricultural drought using VHI, the techniques used for SPI are similar except the 
range and thresholds of the values.   

STEPS (10):  

Classify VHI values to standard classes  

1. Open ArcMap and add the following VHI layers from X:UG_data\Module3\Drought\VHI 
folder  

● VHI_Week 1 September 2008.tif  
● VHI_Week 1 September 2009.tif  
● VHI_Week 1 September 2016.tif  

 

2. Now classify the layers. Right click on the VHI_Week 1 September 2009 layer and go to 
symbology. Under show click on classified and set the number of classes to 6 and click on 
classify to set upper limits of the classes.  

3. Set the class interval 0, 20,40,60,80,100 and click Ok  

4. Now import symbology from X:\UG_data\Module3\Drought\VHI folder and click Ok  choose 
the color range from the color ramp and click Ok.  
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Your map looks similar to the one below.  

 

 

 

 Exercise 3.1  

Produce the agricultural drought map for the first week of September 2008 and 2016  

for all the districts of Uganda and identify top ten districts under severe vegetation 

stress conditions during this Week of the month.   

 

Downloading vegetation Health Index (VHI) data 

Vegetation Health Index (VHI) data can be obtained from NOAA’s Advanced Very High Resolution 

Radiometer (AVHRR). Note that this is available at 4 km resolution and if higher resolution is needed, 

consider to use data from other sources such as MODIS. 

● Open the webpage for downloading VHI’s from NOAA’s AVHRR. 

ftp://ftp.star.nesdis.noaa.gov/pub/corp/scsb/wguo/data/Blended_VH_4km/geo_TIFF/ 

● Scroll to the bottom of the page (note that this is a weekly data, each TIFF file is for the entire 

world, the naming convention includes the year followed by the week). For Example: P201801 

is the first week of January 

● Download all the required weeks to average if you need monthly data. 

VHI values under 40 are considered to be vegetation under stress 

condition and some literature indicated that this is a proxy indicator for 

agricultural drought. This threshold can be used for monitoring agricultural 

drought in the croplands and rangelands).  

 
 

http://ftp.star.nesdis.noaa.gov/pub/corp/scsb/wguo/data/Blended_VH_4km/geo_TIFF/
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3.2.3 Drought, vulnerability and risk assessment  

Elements at Risk 

One of the most important aspect of vulnerability assessment is to identify the elements that are at risk 

of an impending disaster. Depending on the nature of the hazard we can list a number of elements that 

can be at risk and in this case we are working on drought hazard. Let’s consider human and livestock 

population as two elements at risk to further make a meaning to our hazard and risk assessment. These 

information are also key for preparedness, mitigation and response plans. 

 STEPS (11):  

Human Population Counts from Worldpop Data Layer (100 meter resolution) 

1. Load the UGA_population2015.tif layer from X:\UG_data\Module1\Population folder   

2. Double click on  UGA_population2015 and import a symbology_population from 

X:\UG_data\Module1\Population folder  

3. Now your population map should look something like this   
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1. Now load the Drought_hazard_severity.shp layer you produced earlier under Step 9 

2. You have hazard and population layers. Now in order to identify total population exposed to the 

drought hazard based on AMJJASO2009 SPI values you need to generate the total population 

from the population raster above. 

3. Go to Windows >> Search and key in zonal statistics as a table and click to open the tool  

4. Set the  Drought_hazard_severity.shp as input layer and NAME3 as zone field. Set 

UGA_Population2015 as input value raster   

5. Save the output under X:\UG_data\Module3\Output folder with filename 

UGA_population2015_table and Set the statistics to SUM and click Ok  

6. Now we need to join the two table (UGA_population2015_table and  

Drought_hazard_severity.shp 

7. Right click on Drought_hazard_severity.shp layer and  Join and Relate >> Join  

8. Set NAME3 as common field and UGA_population2015_table as a table to join with.  

9. Click Ok and now open the attribute table of Drought_hazard_severity.shp and right click on 

the field MEAN and Sort Ascending and select all records with SPI value < -150  

10. Now go to the SUM field and right click and click on statistics to see the total population of 

districts with SPI value at less than  –150. (Total population exposed to severe drought 

is_______Million) 

 Exercise 3.2 

1) What is the total population exposed to drought condition at SPI less than -200?  

2) For an emergency response planning there is a need to identify districts that are “Very 

Dry” and “Extremely Dry” for this season based on SPI grades. How many people are in 

need of humanitarian assistance assuming that 60% of the population are vulnerable in 

each of the districts?  Hint: Select target SPI grades and calculate the total population.  

 

Vulnerability 

The conditions determined by physical, social, economic and environmental factors or processes, which 

increase the susceptibility of a community to the impact of hazards. Some countries are more vulnerable 

to a certain hazard than others. Even in one country some regions and districts can be more vulnerable 

to a specific type of hazard than the others. This is due to several factors including physical, economic, 

social, cultural…etc factors. The east Africa region, for instance is vulnerable due to over dependence on 

natural resources and primary activity, over reliance on rain- fed agriculture, low level of development, 

inadequate institutional and economic capabilities among many others. 

Mapping vulnerability requires to look at several factors including those mentioned above and even more. 

For now we will be using the following indicators;
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Factor Indicator Range/threshold/criteria Remark 

 
 
 
 

PHYSICAL 
 
 
 
 
 
 
 
 
 
 
 
ECONOMIC 
 

   

Access to major Roads 
(Primary, Secondary and 

tertiary roads only)  
(data source: 
Roads/HDX) 

 
 

 
 

 
 
 

Livelihoods 
(data source: FEWSNET)  

 very poor/Inaccessible (>30km)  
- Poor Access(20-30km > 4/5hrs)  

- Moderate Access(10-20km) 3/4 hrs,   

- Very Good Access (<10km) 1 ½ -2hrs  

 

 

 

 

 

 

 

Very highly,  
 High   
low 

Very low  
 

 
 
 

 

   
Level of Poverty/count  
Data Source: WRI 

 

  Extreme  
Very high (>50)  

High (40-50%), Medium (20-40%) 
Low (<20%)  
Very low  
  

 
 

 

 
You can combine all of these layers to produce a vulnerability map that shows a combined effects of 

factors across the country. 

 

STEPS (12):  

How to Combine Several Layers to Produce Vulnerability Map 

Important: Before you start, make sure that all the layers are important indicators and represented with 

a correct data. All you GIS data needs to be in raster format and the layers have same number of classes. 

It is also important to make sure the number ranking reflects or measures the level of importance or level 

of severity for vulnerability. 
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1. Load the following three layers from X:\UG_data\Module3\Drought\Vulnerability folder 
● Livelihoods.tif 
● Access to Roads_.tif 
● Poverty_count.tif 

2. Go to Windows >> Search >> raster calculator. Open rater calculator 

3. Now you will add all the layers and combine all. But before that you need to give weight to 
each of your parameters based on their importance to decide the output. For this exercise 
Let's assume that Poverty is the most important factor to determine Vulnerability and gets 
60% weight. Livelihoods will get 30% and Access to roads, 10%.  

4. Double click Poverty_count layer to add it to the raster calculator and use multiplication (*) 
operator and give a weight (0.6). Click on the plus sign  (+) and add Livelihoods and 
multiplied by 0.3 and Click on the plus sign  (+). Now double click on Access to roads and 

multiply it by 0.1. The raster calculator should look something like this.  
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5. Name the output raster as Drought vulnerability.tif and save it under 
X:\UG_data\Module3\Output folder and click Ok 

6. The values of the pixels indicate level of vulnerability and go to symbology and use 
stretched the raster from high to low values. You can see such a map 
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Can you explain this map with the necessary precaution for preparedness 

planning? What are the strength and weaknesses of this map?.  

You can also take this result further to combine it with drought hazard map (SPI) for AMJJASO 2009/2015 

to produce drought risk map for 2009/2015. The poverty and related layers can be added to depict the 

lack of capacity indicated in the risk equation. 

 STEPS (13):  

How to Produce a Risk Map (Example) 

3.2.3.1.1 Risk is a factor of hazard, exposure and vulnerability versus capacity. You have two of 
the layers  

1. Open the Drought_hazard2009.tif  and Drought vulnerability_.tif layers from 

X:\UG_data\Module3\Risk folder  

2. As you can notice the two layers are standardized and classified into five classes. Now go to 

Windows >> Search for Raster calculator and open it  

3. In the Raster calculator double click on drought_hazard2009 and give it a weight 

of 0.75 and click on multiplication (*) sign and double click on vulnerability and 

multiply it with 0.25. This is to indicate that the hazard map is by far the important 

determining factor (3/4th) compared to the vulnerability. This is to say where there is 

no hazard vulnerability alone can’t produce a risk.  

 

4. Set the output name to Drought Risk_AMJJAS2009.tif and save it under 
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X:\UG_data\Module3\Outputs folder and click Ok to run the operation 

Now you can open the drought risk layer and stretch it from high to low grades for example to show low, 

medium and high drought risk areas for the AMAMJJASO 2009 season. 

  

 

Which districts are at high drought risk for the given season/year?  
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3.2.4 Flood Hazard Assessment  

Learning Objectives:  

● Causes of Floods? 

● What is a Flood Hazard? 

● Flood Hazard Assessment Methods 

○ Use of Historical data (the past flood approach) 

○ Hydrological and hydraulic approach (flood modelling) 

○ Temporal Satellite Data Analysis 

● Understand Flash Flood hazard assessment using using Flash Flood Potential Index (FFPI).  

● Understand Riverine Flood hazard assessment using GIS Flood Tool (GFT)  

● Understand the advantages and limitations of various flood hazard assessment methods 

 

GLOSSARY 

Cross section is the distance perpendicular to the direction of flow 

Discharge is the rate of flow of water measured in terms of volume over time (i.e. the amount of water 

moving past a point). Discharge and flow are interchangeable. 

Flow Accumulation tool calculates accumulated flow as the accumulated weight of all cells flowing into 

each downslope cell in the output raster. If no weight raster is provided, a weight of 1 is applied to each 

cell, and the value of cells in the output raster is the number of cells that flow into each cell. The result of 

Flow Accumulation is a raster of accumulated flow to each cell, as determined by accumulating the weight 

for all cells that flow into each downslope cell. 

 

Source:ESRI 

Flow direction tool calculates the direction water will flow using slope from neighboring cells. This is 

usually determined by the direction of the steepest descent in each cell.The result is a raster of flow 

direction from each cell to its steepest downslope neighbor. 

Flood level is the height or elevation of floodwaters relative to a datum. 

 
Source:Environment and Climate Change Canada 
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Floodplain is the land adjacent to a river or creek that is periodically inundated due to floods. The 

floodplain includes all land that is susceptible to inundation by the probable maximum flood event. 

Hydrologically conditioned DEM(Hydro DEM) is a DEM whose flow direction defines expected flow of 

water over the terrain (DEM). 

Peak flood level, flow or velocity is the maximum flood level, flow or velocity occurring during a flood 

Runoff is the amount of rainfall from a catchment that ends up as flowing water in the river or creek. 

Watershed is the area where all the water that is under it or drains off of it goes into the same place. 

 
Source: NASA 

Causes of Floods? 

Causes of floods can be due to various reasons, such as natural, man-made and Effect of climate change. 

These are categorized into,  

Natural: Flash floods, Flood, Coastal Flood (due to cyclones/typhoons) 

Man-made: Urban development/ drainage congestion, Dam failures, Watershed activities 

(deforestation) 

Climate Change Effect.  

Flood: An overflow or inundation that comes from a river or other body of water and causes or threatens 

damage. Any relatively high stream flow overtopping the natural or artificial banks in any reach of a stream 

is known as flood. 

Flash flood: The result of heavy or excessive amounts of rainfall within a short period of time, usually 

less than 6 hours, causing water to rise and fall quite rapidly. 

What is a Flood Hazard? 

To analyse the nature and mechanisms of flooding including frequency, velocity and magnitude. Floods 

need to analyse floods qualitatively and quantitatively with the aim of gaining an understanding of the 

nature of flooding to: 

• Identify the probability of a flood occurring. 

• Identify the specific future time period. 

• Identify the area and intensity of impact. 
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Source: UNISDR, 2004.  

Flood Hazard Assessment Methods 

Flood hazard assessment can be conducted in various ways depending on the data availability. The 

method of carrying out the assessment depends on the information, technology and resources available. 

Most commonly used methods are  

● Identifying the probability of flood occurrence 

● Flood Modelling (Hydrological and Hydraulic) approach 

● Temporal Satellite Data Analysis 

 

Identifying the probability of flood occurrence: The return interval, or return period, places magnitude 

of floods in terms of their expected frequency giving a probability of a particular flood occurring. There 

are a vast number of methods that can be used to calculate or determine return intervals based on the 

data or lack of data available. This is assessed using the historical data of past flood events and popularly 

known as flood frequency analysis.  

The 100-year flood is a common design flood use delineate floodplains and design structures. Often there 

are not enough records to determine the magnitude of the 100-year flood; this must then be done by 

empirical extrapolation using frequency distributions (WMO 1999). 

Output from the probability of flood occurrence (Flood Frequency Analysis) will be Flood gauge height for 

different probability of flood occurrence. Different gauge heights can be used to map flood extents of 

different probability of flood occurrences in a GIS environment to delineate flood hazard zones. 

An example of flood frequency is shown in box below.  

 

 Flood frequency calculations based on the annual maximum flood series 

 

This method is widely used for determining the probability and return period for floods.  Ideally there 

should be records for more than 20 years for it to be more representative. 

 

Data Required: 

Peak Flood discharge (Q) every year for a particular gauging station Date and time peak discharge 

occurred.  

 

Rank the Data set with the largest discharge (Q) volume ranked as 1, second largest as 2, etc. 

       Q      M (rank) 

21       1 

19       2 

14       3 

14       4 

13       5 

9         6 

9         7 

8         8 

 

 Compute the recurrence interval (or return period) of each flood using the formula: 
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Tr =  (N+1) / M 

M = rank; N = total number of floods; The units of Tr  are years. 

When Q  = 19m /sec, M = 2, N = 8 

                                 Tr = (8+1) / 2 =  9 / 2 = 4.5 years  

 

To determine the probability use the formula: P =  1/ Tr 

 

  Probability = 1/4.5 = 0.22 probability (22%) for any year that a flood of that size will be equalled or 

exceeded. 

 

Note: The probability information (0.22 or 22%) is most useful as it easier for the public to 

understand. Using the recurrence interval (4.5 years) may confuse people and lead them to believe 

that the flood will only happen at the given intervals. 

The relationship between the return period and probability of occurrence, stage / water level and 

damage is shown in the figure below.  

 

Flood Hazard is usually categorized as high, medium and low and very low intensity as per the 

magnitude of maximum river discharge return period / probability indicated in the following table.  
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Table 3.7: Classification of Probability 

Flood Hazard Category  Return Period (years) Probability (%) of occurrence 

High < 10  >  0.1 

Medium 10 to 50  0.1 to 0.02  

Low 50 to 200 0.02 to 0.005 

Very Low > 200  < 0.005 

Source: Review of Flood hazard Mapping, EU, 2008. 

Exercise 3.3: Flood Frequency Analysis 

Introduction 

The return interval or return period, places magnitude of floods in terms of their expected frequency 

giving a probability of a particular flood occurrence. The method that is used to calculate or determine 

return periods based on the available data i.e. historical data of flood events, is popularly known as 

flood frequency analysis. 

A 100-year flood is a common design flood use delineates floodplains and design structures. Often there 

are not enough records to determine the magnitude of the 100-year flood; this must then be done by 

empirical extrapolation using frequency distributions (WMO 1999). 

Output from Flood Frequency Analysis is the probability of flood occurrence for different flood gauge 

heights. Different gauge heights can be used to map flood extents of different probability of flood 

occurrences in a GIS environment to delineate flood hazard zones. 

 Learning Objectives 

  

1.    Analyze historical data of flood events and calculate the return period or probability of 

occurrences for different flood gauge heights. 

Data Inputs 

Annual Peak Flood discharge (Q) at a particular gauging station as long as possible along with date / 

year of occurrence.   

 Methodology 

1. Arrange the Annual Peak Flood discharge data in descending order (highest to lowest) and 

rank the largest as 1, second largest as 2, etc. 

2. Compute the recurrence interval (or return period) of each flood using the formula: 

                                    T =  (N+1) / M 

 N = Total number of years of flood discharge data available 

M = Rank of the flood discharge considered for analysis 
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T  = Return period of flood discharge considered for analysis 

 3. Calculate the probability of occurrence, P =  1/ T 

Exercise 

1.    Annual Peak Flood discharge data is given below and arrange it in descending order and rank 

them.  

2.    Calculate the return period and also probability of occurrence. 

 

Year Annual Peak Flood 

discharge (m3/s) 

  Annual Peak 

Flood 

discharge 

(m3/s) 

Rank Return 

Period 

(years) 

Probability of 

Occurrence 

1985 77           

1986 358           

1987 34.4           

1988 50.8           

1989 9.88           

1990 111.8           

1991 116           

1992 112           

1993 15.42           

1994 24.6           

1995 44           

1996 35.8           

1997 92           
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1998 113.94           

1999 41.2           

2000 26.6           

2001 24.6           

2002 56.8           

2003 23.2           

2004 17.12           

2005 9.9           

2006 3.46           

2007 50.6           

2008 116.6           

2009 20.2           

 

3. What is the return period and probability of occurrence of a flood discharge of 50.6 m3/s. 

Return period =                                                  Probability of occurrence = 

4. What is the return period and probability of occurrence of a flood discharge of 111.8 m3/s. 

Return period =                                               Probability of occurrence = 

Conclusions: 

As the return period ................................, probability of occurrence ................................ 

 Own Observations from this exercise: 

 _________________________________________________________________________ 

 _________________________________________________________________________ 
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 Flood Modelling (Hydrological and Hydraulic) approach: 

Models can be used to determine the occurrence of floods based on actual or hypothetical rainfall events. 

Flood simulation is achieved by combining a hydrological model to predict flood flows with a hydraulic 

model to predict inundation levels. Conceptually, hydrologic and hydraulic modelling is shown in figure 

below.  

 
Hydrologic and Hydraulic Modelling  

Many hydrologic models exist in literature, however most popularly used models are given here.   

Model Web Link Model Description 

HEC-HMS //www.hec.usace.army.mil/ 
software/hec-hms/ 
 

Hydrologic model which can be used to 
generate flood 
hydrograph at any selected location in the river 
system  

HEC-RAS  
 

//www.hec.usace.army.mil/software
/hec-ras/ 
 

HEC-RAS Version 5.0 has the ability to perform  
one- 
dimensional (1D) and two-dimensional (2D) 
hydrodynamic routing within the unsteady flow.  

Note: There are many more models are available. However more easily usable models are given 

above.   

Components of hydrologic modelling using HEC-HMS to predict flood flows is pictorially shown here.  
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Components of Hydrological Model 

Components of hydraulic modelling using HEC-RAS to predict inundation levels is pictorially shown 

here.  

 

Components of Hydraulic Model 

 

Temporal Satellite Data Analysis: 

The pre and post flood satellite data is quite useful for assessing the extent of flood. The pre and post 

flood satellite data has to be rectified geometrically with a suitable projection system and registered 

exactly. Otherwise errors will arise while composing and computation of statistics of flood inundation 

areas. Always rectify a satellite scene with respect to a topographic map and use it as a master for all 

other scenes so as to maintain the uniformity. The ground control points should be uniformly distributed 

over the area of interest so that the registration will be perfect. In case of microwave data the speckle has 

to be removed using filters. From experience it is found median filter will suppress speckle to the 

satisfactory levels. 
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Optical Satellite Data: Optical remote sensors measure the reflectance from objects on the ground.  

Pure and deep-water bodies absorb most of the electro-magnetic energy and reflect very little energy.  

Flood water, because of different sediment concentrations, reflects considerable energy in different 

bands, including near infra-red (NIR) region. The flood water signature generally mixes with cloud shadow 

and also with mixed pixels of cloud and cloud shadow. In some cases, it mixes with large urban areas / 

built up lands. Flood inundation layer is extracted by various techniques such as visual interpretation, 

unsupervised and supervised classification using satellite data acquired in optical wavelengths. A sample 

flooded area represented in optical satellite data is shown below.  

 
Flood area represented in optical satellite data 

Using this data, either supervised or unsupervised classification techniques is to be used. In case of 

supervised classification maximum likelihood classification can be used. Care must be taken to see the 

different signature of water are given as training sets since the spectral signature varies with turbidity of 

water. After classification check the classification accuracy. Since no ground information will be available, 

it is better to overlay the classified layer over the image and check whether the classification is proper or 

not. The flood image as well as the pre flood image has to be classified. 

Using arithmetic operations the extent of water in the pre-flood image has to be subtracted from the flood 

image so as to delineate the inundation due to flood. In this process, all the permanent water bodies as 

well as pre Flood River courses will be subtracted resulting net flood inundation.  

Microwave satellite data:  The advantage of using radar data over the optical data is its ability to 

penetrate cloud cover and also data acquisition during day and night.  Water surfaces are generally 

smooth at radar wavelengths and can be regarded as specular reflectors which yield small backscatter.  

Hence, water is regarded as low intensity areas whereas the surrounding terrain corresponds to brighter 

intensities, as shown in figure below.  

 
Flood area represented in microwave satellite data 
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In case of microwave data, back scatter (db) values have to be computed and the image has to be 

classified. If the data is available in full resolution and with all other parameters only, the db values can 

be computed. However in case of near real time flood monitoring the data will be received in compressed 

format (Radarsat data) through ftp. In such case the data has to be classified using threshold technique. 

Intensities below the threshold are regarded as flood or open water, whereas pixels with intensities above 

the threshold are regarded as dry land.  The threshold will depend on the contrast between the land and 

water classes, and generally needs to be set for each SAR scene.  The backscatter depends on the 

frequency, incidence angle, polarization and is sensitive to the ripples on the water surface induced by 

wind waves. The demarcation between water and land is distinct, at higher incidence angle of 45º and is 

difficult at 23º incidence angle and may lead to error in classification.  This is because the contrast 

decreases with decreasing incidence angle.  

Thresholding / density slicing technique are used for satellite data acquired in microwave wavelength. It 

is most common when the data is classified there will be some scattered pixels will get misclassified may 

be due to spectral overlap. These unwanted pixel has to be removed either manually or using sieving 

techniques. Especially cloud shadows in optical data and hill shadows in microwave data will interfere 

with water delineation. After necessary editing the final inundation layer has to be generated.  

Exercise 3.4: Flash Flood Hazard Assessment using Flash Flood Potential Index (FFPI)  

What is Flash Flood Potential Index (FFPI)?  

Flash flooding is the top weather-related killer, responsible for severe damages including causality of 

people in many countries. Although precipitation forecasting and understanding of flash flood causes 

have improved in recent years, there are still many unknown factors that play into flash flooding.  Despite 

having accurate and timely rainfall reports, some river basins simply do not respond to rainfall as 

meteorologists might expect.  The Flash Flood Potential Index (FFPI) was developed (Smith, 2003) in 

order to gain insight into these “problem basins”, giving meteorologists insight into the intrinsic properties 

of a river basin and the potential for swift and copious rainfall runoff. Thus, the FFPI can be added to the 

situational awareness tools, which can be used to help assess flash flood risk. 

 

Learning Objectives 

 1.    Understand the concepts of FFPI 

2.    Input geo-spatial data requirement and data availability 

3.    Development and Analysis of FFPI 

 Data Inputs 
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Data Type of 

Data / File 

Format 

Specifications Source File Name Data Path 

Digital 

Elevatio

n Model 

(DEM) 

Raster / Tif Resolution: 90 m SRTM UG_DEM.

tif 

UG_Data\Module3\Floo

d\FFPI\Input\Raster\ 

Land 

Cover/U

se 

Vector / 

Shapefile / 

Layer  

- http://www.fao

.org/geonetwo

rk/srv/en/main

.home 

UG_Lulc.s

hp 

UG_Lulc.l

yr 

\UG_Data\Module3\Floo

d\FFPI\Input\Vector 

Soil 

Type/Te

xture 

Raster / Tif Resolution: 1 

Km 

FAO 

Harmonized 

World Soil 

Database V 

1.21 

UG_Clay

P.tif 

UG_Sand

P.tif 

\UG_Data\Module3\Floo

d\FFPI\Input\Raster\ 

Uganda

_Admin3 

(level 3) 

Vector / 

Shapefile 

- ICPAC UG_Admi

n3.shp 

\UG_Data\Module3\Floo

d\FFPI\Input\Vector 

Watersh

ed 

boundar

y 

Vector / 

Shapefile 

- Hydrosheds UG_Wshe

ds.shp 

\UG_Data\Module3\Floo

d\FFPI\Input\Vector 

 

Methodology 

 The concept of FFPI is fairly simple and the goal is to quantitatively describe a given sub-basin’s risk of 

flash flooding based on the process involved acquiring or developing raster (gridded) datasets that 

represent the type of physiographic characteristics i.e. slope, land cover, land use and soil type/texture 

that influence the hydrologic response and flash flood potential. The FFPI is composite index value the 

physiographic characteristics of a basin represented by the layers of Slope, Soil and Land Cover/Use (L) 

and Vegetation Cover/Forest Density (V). These datasets can be compiled from the available local or 

global datasets. FFPI is composite index value of the layers of Slope, Soil and Land Cover/Use (L) and 

Vegetation Cover/Forest Density (V) index maps averaged together, as given in the equation below by 

Smith (2003). 
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                                                                                                   (1) 

 where 

M = Slope 

L = Land Cover/Use 

S = Soil Type/Texture 

V = Vegetation Cover/Forest Density 

N = Sum of weights 

A relative flash flood potential index ranging from 1 to 10 was assigned to each data layer based on the 

layer attributes associated with the hydrologic response. An index value of 1 indicates a minimum flash 

flood threat and an index of 10 indicates a maximum flash flood threat. By indexing a given sub-basin’s 

risk of flash flooding, the FFPI allows the user to see which sub-basins are more predisposed to flash 

flooding than neighboring cells. The values are unit-less. 

 Exercise 

The datasets required for FFPI represent the physiographic characteristics of the terrain i.e. Slope, Soil 

and Land Cover/Use (L) and Vegetation Cover/Forest Density (V) index. 

Slope (M): Slope is an important component in flash flooding potential, due to the potential for rapid 

runoff. Experience suggests that any slope exceeding 30 percent leads to extremely quick runoff and a 

rapid response in local creeks and streams.  Therefore, the formula below was created to reclassify 

percentage slope into an FFPI value, setting any slope of 30% or higher to an FFPI of 10. 

                                                   (2) 

Where 

n = percent slope ≤ 30.  If n > 30, then FFPI = 10. 

●  Open the existing ArcMap project (workspace) “FFPI_Uganda.mxd” stored on: 

X:\UG_Data\Module3\Flood\FFPI\Input\Workspace\ 

● Check the input data given above, in Table of Contents (TOC). 

● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Surface > Slope 

● Select the Input Raster “UG_Dem.tif” from the following location: 

X:\UG_data\Module3\Flood\FFPI\Input\Raster\ 
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● Select the Output Raster “Slope_per.tif” in the following location: 

X:\UG_data\Module3\Flood\FFPI\Output\Raster\ 

●  Select the “PERCENT_RISE” for Output measurement (optional) 

● Click OK 

 

●  Slope Index will change for slope < 30%,    

 

 If slope is > 30%, Slope Index = 10. 

  

Convert the slope map into Slope Index using the above formula, using Raster Calculator. 

● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Map Algebra > Raster Calculator. 

● In Raster Calculator Expression window, write the expression (use the available functional tools) 

given below. 

 Con("Slope_per.tif" <= 30.0,Power(10.0,"Slope_per.tif"/30.0),10.0) 

● Select the Output Raster “SlopeIndex.tif” in the following location 

X:\UG_Data\Module3\Flood\FFPI\Output\Raster\ 

● SlopeIndex map should look like as given below. 
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Land Cover/Use (L) and Vegetation Cover/Forest Density (V): The land cover /use dataset includes 

many different components, including biophysical settings, existing vegetation cover (EVC), existing 

vegetation height and existing vegetation type.  The FFPI uses solely the EVC component because it 

was overall the most applicable to flash flood threat assessment. EVC essentially combines vegetation 

cover and land use into one composite dataset, using the percentage of canopy cover for tree, shrub and 

herbaceous canopy cover. 

The land cover data set used is derived from the original raster based Globcover regional 

(Africa) archive. It has been post-processed to generate a vector version at national extent with 

the LCCS regional legend (46 classes).This database provides a user-friendly interface and 

advanced functionalities to breakdown the LCCS classes in their classifiers for further 

aggregations and analysis. 

More details are available at http://www.fao.org/geonetwork/srv/en/main.home. The shape file's 

attributes contain the following fields: -Area (sqm) -ID -Gridcode (Globcover cell value) -

LCCCode (unique LCCS code). The land use data is assigned appropriate FFPI values based 
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on the literature review (Zogg and Deitsch, 2013) and given in table 1.The values were 

subjectively assigned because it would be extremely difficult to scientifically document the 

contributions of vegetation to water runoff. Some of these values were simply assigned based 

on tree, shrub and herb cover categories.  

Table 1: Flash Flood Potential Index value for Land Cover/Use (L) and Vegetation 

Cover/Forest Density (V) 

Aggregated Land use Category (FAO LCCS Categories) FFPI 

Agriculture (AG) 5.5 

Barren Area (BA) 8 

Natural Vegetation Terrestrial (NVT) 4 

Natural Vegetation Aquatic (NVW) 5 

Urban Areas (UR) 8.5 

Water Bodies (WAT) 1 

Note: An index value of 1 indicates a minimum flash flood threat and an index of 10 indicates a maximum 

flash flood threat. 

● Using the Conversion Tools > To Raster > Feature to Raster. 

● Select the Input Features “UG_Lulc” from the following location: 

X:\UG_data\Module3\Flood\FFPI\Input\Vector\ 

●  Select Field “Lulc_Index.tif (FFPI value for each land use category). 

● Select Output Raster “Lulc_Index.tif” in the following location 

X:\UG_Data\Module3\Flood\FFPI\Output\Raster\ 

● Select Output Cell size (optional) “SlopeIndex.tif” 

● Click OK 

 

Lulc_Index map should look like as given below.  
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Soil Type/Texture (S): Sand and Clay are very important components of soils when assessing runoff 

potential.  A soil type consisting of 100% sand will lend very little surface runoff, while 100% clay soils will 

maximize runoff. The soil type raster was reclassified according to the equations below into two new 

indexed rasters, one for percent clay and one for percent sand.  These values were then averaged to 

calculate Soil Index. 

 

 Where n  = percent clay. 

● Select “UG_ClayP.tif” in the ARC map window. 

● Bring up Arctoolbox by clicking the  button 

● Go to Spatial Analyst Tools > Map Algebra > Raster Calculator. 
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● In Raster Calculator Expression window, write the expression (use the available functional tools) 

given below. 

 0.5 * ((1.0 + ("UG_ClayP.tif" / 100.0)) * 9.0) 

● Select Output Raster “ClayIndex.tif” in the following location 

X:\UG_data\Module3\Flood\FFPI\Output\Raster\ 

● Click OK. 

 

 

 Where n = percent sand. 

● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Map Algebra > Raster Calculator. 

● In Raster Calculator Expression window, write the expression (use the available functional tools) 

given below. 

 0.5 * ((1.0 + ((100.0 - "UG_SandP.tif") / 100.0)) * 9.0) 

● Select Output Raster “SandIndex.tif” in the following location 

 X:\UG_Data\Module3\Flood\FFPI\Output\Raster\ 

● Click OK. 
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● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Map Algebra > Raster Calculator. 

● In Raster Calculator Expression window, write the expression (use the available functional tools) 

given below. 

0.5 * ("ClayIndex.tif" + "SandIndex.tif") 

● Select Output Raster “SoilIndex.tif” in the following location 

 X:\UG_Data\Module3\Flood\FFPI\Output\Raster\ 

● Click OK. 
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● SoilIndex.tif map should look like as given below. 
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● Now using the Slopeindex.tif, SoilIndex.tif and LulcIndex.tif maps calculate Flash Flood 

Potential Index for Uganda, using Spatial Analyst Tools > Map Algebra > Raster Calculator. 

 

 FFPI = 0.5 * (slopeindex.tif + soilindex.tif + lulcIndex.tif)  / 3 

● Select Output Raster “FFPI_UG.tif” in the following location 

 \UG_Data\Module3\Flood\FFPI\Output\Raster\ 

● Click OK. 

 
 

● As you observed the minimum and maximum range of FFPI is 1.128 and 3.98. For better 

visualization, let us reclassify it into 3 classes (low, moderate and high) using the limits given 

below. 
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FFPI Class FFPI Min. Range FFPI Max. Range Class Code 

High 3.0 3.98 3 

Moderate 2.0 3.0 2 

Low 1.128 2.0 1 

 

Note: The classification ranges are subjective. Share your field experience in deciding them. 

● Use the above range of FFPI values to classify the FFPI map of Uganda using Raster 

Calculator. 

● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Map Algebra > Raster Calculator. 

● In Raster Calculator Expression window, write the expression (use the available functional 

tools) given below. 

 Con(“FFPI_UG.tif” <= 2.0, 1, Con(“FFPI_UG.tif” >= 3.0, 3,2)) 

●  Select Output Raster “FFPI_UG_cls.tif” in the following location 

X:\UG_Data\Module3\Flood\FFPI\Output\Raster\ 

● Click OK. 

 

● The classified FFPI map of Uganda is given below. 
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Which sub-District in Uganda has highest Flash Flood Potential?   

● Let us now assess the mean FFPI within each sub-district (Admin 3). 

● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Zonal > Zonal Statistics as Table. 

● Select the Input Raster or Feature Zone Data “UG_Admin3” from the following location: 

  

X:\UG_Data\Module3\Flood\FFPI\Input\Vector\ 

● Select Zone Field “Admin3Name” 

● Select the Input Value Raster “FFPI_UG.tif” in the following location: 

X:\UG_Data\Module3\Flood\FFPI\Output\Raster\ 

● Select the Output Table “Mean_FFPI_Admin3” in the following location: 

X: \ETH_Data\Module3\Flood\FFPI\Output\ 
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●  Select Statistics Type (optional) “MEAN” 

● Click OK. 

                                                    

                                  
 

● Open the Table “Mean_FFPI_Admin3” to see the Mean FFPI value for each sub-district in the 

field “MEAN”. 

● Analyse the table “Mean_FFPI_Admin3” and answer the following questions.  

 

Questions 

 

1.    In which sub-district the mean FFPI is highest?   

        ______________________________________________________________________ 

 

2.    In how many sub-districts the mean FFPI is more than 3.0? 

  

______________________________________________________________________ 

 

How many watersheds in Uganda have highest Flash Flood Potential?   

 

● Let us now assess the mean FFPI within each watershed. 

● Bring up Arctoolbox by clicking the  button 

● Go to Spatial Analyst Tools > Zonal > Zonal Statistics as Table. 

● Select the Input Raster or Feature Zone Data “UG_watersheds” from the following location: 

  

X:\UG_Data\Module3\Flood\FFPI\Input\Vector\ 

  

● Select Zone Field “FID” 
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● Select the Input Value Raster “FFPI_UG.tif” in the following location: 

  

X:\UG_Data\Module3\Flood\FFPI\Output\Raster\ 

 

● Select the Output Table “Mean_FFPI_Wsheds” in the following location: 

  

X:\UG_Data\Module3\Flood\FFPI\Output\ 

  

● Select Statistics Type (optional) “MEAN” 

● Click OK. 

 

 
 

● Analyse the table “Mean_FFPI_Wsheds” and answer the following question. 

 

Questions 

 

1.    In how many watersheds the mean FFPI is more than 3.0?   

    

 __________________________________________________________________ 

 

Own Observations from this exercise: 

 

 _________________________________________________________________________ 

 

 _________________________________________________________________________ 

 

_________________________________________________________________________ 
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_________________________________________________________________________ 

 

Exercise 3.5: FLOOD WATER EXTRACTION USING SENTINEL-1 RADAR DATA 

  

Thresholding 

Through this process all pixels that belong to a range of pixel values corresponding to the feature you 

want to extract are assigned a value 1. All other pixels in the image are assigned a value 0. 

 

Identification of initial threshold value 

For this exercise you will now extract the pixel values likely corresponding to water. Before starting, 

 

● Open “Flood_Hazard_Analysis.mxd” in ARCMap. (This is data from Exercise 2.2) 

X:\UG_Data\Module_3\Flood\Hazard\WorkSpace\ 

● Use the Identify tool on the Tools toolbar to view the attribute information of the raster image 

including the pixel values corresponding to water, which is the feature you want to extract from 

the image (make sure that the concerned raster layer is the selected layer in the Identify tool 

Window). 

 
What is the best threshold of pixel values to apply in order to identify and to extract those pixels 

likely corresponding to water/flood areas? 

  

_________________________________________________________________________ 

 

Identification of Optimal threshold value 

  

Now that we have an idea of what the threshold value can be, we are going to classify water and not 

water pixels. First we are going to calculate the statistics of the raster dataset “Flood_23082017.tif 
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● Bring up Arctoolbox by clicking the button 

● Go to Data management tools > Raster > Raster properties > Calculate Statistics 

● Select the raster dataset “Flood_23082017.tif,  from the following location: 

X:\UG_Data\Module_3\Flood\Hazard\Input\Raster\ 

 

● Click OK 

 
 

This Calculate Statistics operation will allow us to apply classified visualization from the Symbology tab. 

  

Now we are going to create a duplicate of “Flood_23082017.tif, and apply a classified visualization to it: 

·    Right click the image layer “Flood_23082017.tif” > Copy 

 

·    Right click on Layers and Click Paste. Another copy of  “Flood_23082017.tif””  will be added 

to the ToC. 

  

Note: This creates a copy within your mxd of the layer you are working with, NOT a copy of the actual 

image itself. 

  

Now you will work on the image copied now (which is above the original image in ToC) 

  

Right click the image layer “Flood_23082017.tif” >Properties>Select the Symbology 

tab. 

Select Classified. 

 Under Classes select 2 and click on the Classify button. 

Under Break Values enter your threshold value as the first value and click OK 
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You now have two classes in your image, one below your threshold and one above. 

  

·         Double Click on the color box next to the class representing water and give it a 

color (e.g. red). 

·         Double Click on the color box next to the class representing everything else and 

select NoColor 

 
 

·         Click on OK. 

  

What is The Threshold you used? ________________________________ 
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If you are not satisfied with your threshold for flood water, please change the threshold in the Break 

Values in the Classification window. 

 

Repeat this process until you are satisfied with the suitable threshold value. 

  

Now that you have identified a suitable threshold of pixel values corresponding to water, you can start to 

proceed with the pixel-based classification process using a raster calculator: 

  

● Using the Search toolbox, open Raster Calculator 

● In the Raster Calculator tab, double click on the raster layer “Flood_23082017.tif”” and insert 

the following mathematical expression using the most suitable identified pixel value threshold: 

  

“Raster Layer” <= Threshold Value 

  

(Type the numeric value corresponding to the threshold value for water, identified by using the 

Identify tool) 

● To set the processing extent, click the Environments... >Processing Extent> AOI 

 
 

● Name the output raster layer as “Flood_ext_AA.tif“and save it in the output raster folder: 

 X:\UG_Data\Module_3\Flood\Hazard\Output\Raster\ 

  

Pay attention to add also the extension (e.g. “.tif”) in the name of the output raster. 

  

● A new binary raster layer will be added in the ToC: Value 1 is assigned to the pixels values with 

similar spectral characteristics corresponding to water (as defined by the formula you typed in 

the Raster Calculator), and Value 0 is assigned to the rest of the pixels. 

● Use the Swipe Tool available from the Effect Toolbar and check your raster analysis results by 

comparing the binary raster layer with the original image. To improve your results, you will 
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probably need to apply different threshold values in the Raster Calculator and repeat the above 

process. 

 
If at any point, your raster image is appearing to be completely black: 

● Right click on that layer >Properties > Symbology >Under Stretch >Type: Standard Deviation 
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Filtering and converting extracted flood water from raster to vector 

  

Filters are used to improve the quality of the raster image by eliminating spurious data or enhancing and 

smoothing features in the data. 

● From the Spatial Analyst tools>click on Neighborhood >Focal Statistics 

● Select “Flood_ext_AA.tif” as input raster and apply the filter parameters as below: 

 

 

 

● Name the output raster layer as “FocalSt_Flood.tif “ and save it in the output raster folder: 

X:\UG_Data\Module_3\Flood\Hazard\Output\Raster\ 

  

To convert your final flood analysis result from raster to vector: 

  

● Search for the tool Raster to Polygon 

● Add the raster layer from the previous step (“FocalSt_Flood.tif”) and name the vector file to export 

as “Flood_ext_AA.shp” 

● Choose as output location: 

X:\UG_Data\Module_3\Flood\Hazard\Output\Vector\ 

  

● Uncheck the option Simplify polygons 
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● Add the exported vector layer to your ArcMap project. 

● Right click on “Flood_ext_AA.shp” > Edit Feature > Start Editing 

● Right click on the vector layer “Flood_ext_AA.shp” > Open Attribute Table 

● From the Attribute Table Dialog Box, click Table Options > Select by Attributes 

● Double click on GRIDCODE and type in the following query expression: 

GRIDCODE = 0 

 
 

● Once all the GRIDCODE values = 0 are selected you can delete them (step 4) 

● Then in the Editor toolbar click on Editor >Save Edits>Stop Editing 

● Change the symbology of the layer as desired (It is recommended to choose Outline Color: No 

Color). 
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● To add a new attribute field to the Attribute Table, open the Attribute Table >Table Options > 

Add Field and type-in Class as name and select Text as attribute type 

● From the Attribute Table,right click on the field“Class”>Field Calculator and assign to this 

attribute field the text label “Flood Water” (type the quotations marks as well): 
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Satellite Analysis: estimated flood water extent by affected administrative units 

 

Within the immediate aftermath of a disaster, one of the most critical information needed by the 

humanitarian actors is to know spatial distribution and estimation of the water extent (in case of 

flooding). 

  

Using the Search tab, open the tool Intersect 

  

● From the Intersect Dialog Box, select the two layers you want to intersect (“Flood_ext_AA.shp” 

and “UG_Admin3_AOI.shp”) and “NO_FID”as Join Attributes 

● Name the output layer file “Adm3_FloodWater” and choose as output location: 

 X:\UG_Data\Module_3\Flood\Hazard\Output\Vector\ 
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The output file “Adm3_FloodWater” will be automatically added to the TOC: 

 

● Open the Attribute Table and you will notice that all records of the table have now the 

corresponding Admin1 and Admin2 names, which in this case are admin1Name and 

admin2Name.  

To calculate the area (sqKm) for each polygon (record): 

  

● From the Attribute Table, clickTable Options > Add Field… Enter “Flood_sqkm” as Name and 

select Double as Field Type 

● Right click on the field “Flood_sqkm” >Calculate Geometry 

● From the Calculate Geometry Dialog Box, select the following parameters: 

● Click OK 

 
Each record of the attribute table “Admin3_FloodWater” will be filled out with the area in square 

kilometers. Using the Summarize tool in the attribute table, you can summarize the total flood water for 

each affected administrative unit. 

● Right click on admin3Name field in the attribute table, click Summarize, select the fields to be 

included in the output table (Area_sq_km and Flood_sqkm)and check the operations  



 

 

120 
 

 

o Minimum for the field Area_sq_km (you can alternatively check Minimum, Maximum 

or Average and the result will be the same value, as this is a property coming from 

admin level2 boundary and not from the intersect of admin level2 boundary and flood 

water) 

o  Sum for the field Flood_sqkm. 

 
 

● Name the output .dbf table as “Flood_Adm3” and choose as output location: 

  

X:\UG_Data\Module_3\Flood\Hazard\Output\Vector\ 

  

Now you can calculate the percentage of flood water for each affected administrative unit within the AOI. 

● From the Attribute Table, click Table Options > Add Fields… Enter “Perc_Flood” as Name and 

select Double as Field Type 

● Right click on the field “Perc_Flood”> Field Calculator 

● In the Field Calculator Dialog Box, type-in the following formula to obtain the percentage of flood 
area by administrative units (Level 3): 

“(“Sum_Flood_sqkm”/ “Min_Area_sq_km”) *100” 
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Exercise 3.6 EXPOSURE ASSESSMENT OF ELEMENTS AT FLOOD RISK 

3.6.1 Introduction 

In this session, the exposure assessment of the elements at risk co-located within the flood affected area 

is assessed. 

Learning Objectives 

In this session, the participants will be able to combine the flood affected area and the elements at risk 

data and assess the exposure of the elements at risk to flood.  

1.  Understand the geographical extent of flood affected area. 

2.  Quantitative assessment of the exposure of elements at risk to flood, within the Area of Interest. 

Data Input 

The input data used in this module is, 

Descriptio

n 

Data path Data Type File Name 

Area of 

Interest  

\Module3\Flood\Exposure\I

nput\Vector 

Vector 

(polygon) 

Amurui_Adjumani_AOI.shp 

Flood 

Extent 

Area 

\Module3\Flood\Exposure\I

nput\Vector 

Vector 

(polygon) 

Flood_230832017.shp 
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Road 

Network 

\Module3\Flood\Exposure\I

nput\Vector 

Vector 

(polyline) 

Roads_AOI.shp 

Settlemen

ts 

\Module3\Flood\Exposure\I

nput\Vector 

 

Vector 

(point) 

Towns_AOI.shp 

Land use \Module3\Flood\Exposure\I

nput\Vector 

 

Vector 

(polygon) 

Lulc_AOI.shp 

Population 

(Grid) data 

:\Module3\Flood\Exposure\

Input\Raster 

Raster  Worldpop_AOI.tif 

 

 

Output 

Output expected in this session is, 

●   Area of Flood Extent 

●   Length of the road types inundated due to Flood 

●   Land use categories inundated due to Flood 

●   Settlements located in Flood area 

●   Population affected due to flood 

STEP (15) 

Assessment of elements at risk exposed to flood 

 

● Open Flood_Exposure.mxd at X:/UG_Data/Module3/Flood/Exposure/Workspace/ 

  

●   Overlay Flood extent and road network maps to assess the type and length of the roads 

within flood extent. Calculate percentage of road length exposed to floods. 

 Hint: Use Arc Tool Box Analysis Tools > Overlay > Intersect 

 

●   Length of the road types exposed to Flood
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Road Type Length of the Road Exposed to Flood (Km) 

    

    

  

  

  

  

  

  

  

Total   

 

Percentage of the Road length exposed to flood? 

   

________________________________________________________________________ 

   

●   Overlay Flood extent and settlements map to assess the number of settlements located 

within flooded area.  Calculate percentage of settlements located within the flooded area. 

         Hint: Use Arc Tool Box Analysis Tools à Overlay  à Intersect 

   

  ________________________________________________________________________ 

 

●   Overlay Flood extent and land use map to assess the land use categories exposed to flood. 

Calculate percentage of total land use categories exposed to flood. 
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Hint: Use Arc Tool Box Analysis Tools - Overlay – Intersect 

 

● Overlay Flood extent and Population maps to assess the population exposed to flood. 

Calculate percentage of population exposed to flood. 

  

Hint: Use Arc Tool Box Spatial Analyst Tools > Zonal > Zonal Statistics as Table and use Statistics type 

‘SUM’ 

   

________________________________________________________________________ 

 

DISCUSSION 

 

Unlike the two previous flood management related modules, in which the accuracy of the results is highly 

dependent on data that is generated and obtained prior to when the disaster occurs, in this flood impact 

analysis the most important data related factor is to obtain remotely sensed data of the affected areas as 

soon as possible and process it quickly, effectively and with reasonable accuracy. 

 

Obtaining damage figures and breakdowns by administrative units is very useful for planning and 

coordinating humanitarian operations in the field. GIS allows for a very rapid estimation of the extent of 

flood water within affected areas.The timely production of these map products and data can be used by 

decision makers and humanitarian actors to prioritize and coordinate disaster response operations. 

 

What are the two datasets used in the flood impact analysis that can be obtained prior to when the disaster 

occurs (so we are ready to use it when needed)? 

 

 

 

What other sources of data could you have acquired, free of cost, to conduct a similar response 

mapping? 

 

  

Can you identify the potential problems in using Optical data? 

 

  

What are the advantages/disadvantages of using WorldPop data? 

 

 

Could you briefly explain two limitations of the methodology presented in this exercise that may affect the 

accuracy of the final output? 

 

  

 When it comes to flood response mapping, are there any significant issues with the spatial resolution of 

the image being used? In other words, what – in your opinion – would have been the best spatial 

resolution for a flood of magnitude similar to the one used in this exercise? 
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3.2.5  Flood vulnerability and risk assessment  

Flood risk is then normally expressed in terms of the following relationship: 

  
The assessment of flood risk requires an understanding of where the water comes from (i.e.the source), 

how and where it flows (i.e.the pathways) and the people and assets affected by it (i.e. the receptors). 

Pictorially it is shown in figure below. 

                               

  
Figure:  Source-Pathway-Receptor Model 

 

Source: From where the water comes? This is addressed in Flood Hazard Assessment, such as flash 

flood or riverine or coastal storm surge? 

 

Pathways: How and where it flows? This is also addressed in Flood Hazard Assessment, which areas 

are inundated due to flood.  

 

Receptors: The elements at risk such as population, infrastructure, critical facilities and livelihood which 

are exposed to floods are considered as receptors.  

 

 Likelihood of Flooding which is the flood hazard, explained earlier.  

 

Consequence of flooding is vulnerability of exposed elements at risk to flood hazard. Exposure 

assessment of elements at risk is discussed earlier and an exercise was also carried out. Now we will 

understand vulnerability of exposed elements at risk.  

 

Flood vulnerability is one of the significant components in risk management and flood damage 

assessment. Vulnerability measurement is a complex process because it influenced by several 

environmental, economic, and social or even political elements in local scale. In other words vulnerability 

is affected by numerous factors such as settlements conditions, infrastructure, authority’s policy and 

capacities, social inequities, economic patterns, etc. So flood vulnerability is varied for people in diverse 

circumstance.   

  

Human systems are vulnerable to floods due to three vital aspects: Exposure, susceptibility and 

resilience. Exposure refers to people and their surroundings and every element present in flood prone 

area being exposed to the flood impacts as a subject to potential losses. Susceptibility is considered 

status of people, environment and infrastructure tendency to influence by a hazard because of fragility of 

community or ecosystem and resilience, coping and adaptation ability of a system in addressing disaster 
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stress. Instance the vulnerability of urban areas is reflection of the exposure and susceptibility of the city 

to flood risk and the resilience of that region to cope and recover from the flood effects.   

 

An example vulnerability curve is shown here, which indicates the relationship between flood depth (m) 

and percentage of the damage for different types of buildings.  

 

Let us use this vulnerability curve with a building footprint map and assess the flood risk in an exercise.  

 

 
 

Exercise 3.7: Flood Risk Assessment Exercise 

  
Data: Combined building footprint and flood depth map and flood vulnerability curves 
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 Building footprint map and flood depth map 

  
● Flood Depth categories in the given flood map are: 

 

Flood Depth (m)  Color Code in the flood depth map  

1.0   

1.5  

2.0  

 

● Attribute Table for Buildings with details of material, age class and cost of the building 

 

  

S.No. 
  

ID 
  

Material 
Number of Stories Age class 

 

1 3951 Timber 1 Class 1 

2 3959 Timber 2 Class 2 

3 3983 Concrete 1 Class 1 

4 3985 Concrete 2 Class 1 

5 4355 Concrete 1 Class 1 

6 4359 Masonry 2 Class 1 
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7 4366 Masonry 2 Class 1 

8 4373 Masonry 1 Class 1 

9 4443 Masonry 1 Class 1 

10 4449 Concrete 2 Class 1 

 

● Depth - Damage Ratio Curves 

 
 

Methodology 

  
● Using the building footprint map and flood depth map, find the percentage of damage 

to the buildings using the depth - damage ratio curves. 

● Using the cost estimate of buildings, calculate the damage ($) for each type of building. 

  
Result: Using the above data calculate the Damage of each type of building and fill up the table.  
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I
D 

Flood Depth (m)   

Damage Ratio  
Cost of the Building ($)  Damage ($)  

3
9
5
1 

  1000  

3
9
5
9 

  1600  

3
9
8
3 

  7000  

3
9
8
5 

  10000  

4
3
5
5 

  7000  

4
3
5
9 

  6000  

4
3
6
6 

  6000  

4
3
7
3 

  3500  

4
4
4
3 

  3500  

4
4
4
9 

  10000  
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Conclusions based on the analysis: 

What is the important information in this analysis, based on your opinion?   

 

------------------------------------------------------------------------------------------------------------------------ 

 

------------------------------------------------------------------------------------------------------------------------ 

 

To develop a depth-damage curve for Kampala / Uganda, what data you need to collect and how do you 

plan to collect? 

 

------------------------------------------------------------------------------------------------------------------------ 

 

------------------------------------------------------------------------------------------------------------------------ 

Exercise 3.8: Application of Geospatial Tools for Landslide Hazard Assessment for Uganda  

The term Landslide hazard refers to the probability of occurrence within a specified period and within a 

given area, of a landslide, of a given magnitude.  Like most other definitions of hazards, landslide hazard 

definition incorporates three basic elements (i) magnitude, (ii) geographical location, and (iii) time. 

Landslides primarily result from geological, hydrological and geomorphologic factors. Furthermore, the 

effects of landslides on people and property have been mounting in recent decades due to increasing 

slope instability as a result of deforestation, road cutting and urbanization. 

In Uganda, the most destructive landslide occurred on March 1, 2010 in the eastern district of Bududa. 

The landslide is believed to have been triggered by heavy rains that the area experienced on that day 

which had been preceded by a long period of unusually heavy rains. The disaster left about 300 people 

dead, many more people missing, more than 6000 homes displaced and a number of schools closed.  

Landslides have also been reported in the steep mountains of Rwenzori (Western Uganda), Kabale and 

Kisoro (South Western Uganda) and the districts of Sironko and Kapchorwa (Eastern Uganda). GIS and 

related geo-spatial technologies have proved to be useful landslide assessment tools primarily because 

they combine mapping, field inventory, spatial analysis and other tools. 

However, this exercise explores the possibility of adopting geospatial techniques to understand landslide 

hazard assessment in Uganda based on available and accessible spatial data using spatial analysis.  

Learning Objectives 

1. Understand the factors affecting Landslide Hazard 

2. Analyze available geo-spatial data to derive suitable parameters and combine them into 

landslide susceptibility map    

3. Use annual daily maximum precipitation map to transform landslide susceptibility map into 

landslide hazard map 
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 Data Inputs 

Data Type of 

Data / File 

Format 

Specificatio

ns 

Source File Name Data Path 

Digital 

Elevation 

Model 

(DEM) 

Raster / 

Tif 

Resolution: 

90 m 

SRTM UG_DEM.tif UG_Data\Module3\La

ndslide\Input\Raster\ 

Land 

Cover/Use 

Vector / 

Shapefile 

/ Layer 

- http://www.fao.o

rg/geonetwork/s

rv/en/main.hom

e 

UG_Lulc.sh

p 

UG_Lulc.lyr 

\UG_Data\Module3\ 

Landslide\Vector 

Soil 

Type/Textur

e 

Raster / 

Tif 

Resolution: 

1 Km 

FAO 

Harmonized 

World Soil 

Database V 

1.21 

UG_SoiT.tif 

 

\UG_Data\Module3\ 

Landslide\Input\Raste

r\ 

Uganda_Ad

min3 (level 

3) 

Vector / 

Shapefile 

- ICPAC UG_Admin3

.shp 

\UG_Data\Module3\ 

Landslide\Input\Vecto

r 

Population 

(Grid) data 

Raster / 

Tif 

100 m World Pop 

(https://www.wor

ldpop.org/doi/10

.5258/SOTON/

WP00283) 

UG_Worldp

op.tif 

\UG_Data\Module3\ 

Landslide\Input\Raste

r 

Annual 

Long Term 

Normal 

Rainfall 

Raster / 

Tif 

10 Km  UG_Rain.tif 

 

UG_RainRa

nk.tif 

\UG_Data\Module3\ 

Landslide\Input\Raste

r 

Note: Annual daily maximum rainfall data is required, since it was not available, we have used Annual 

Long Term Normal Rainfall data for this exercise.  

 

Methodology 
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The causative factors of the landslides considered in this exercise are 

  

·         Slope 

·         Soil Texture 

·         Land Cover 

·         Population 

  

Forcing parameter considered is 

  

·   Rainfall 

  

Geo-spatial maps of above causative and forcing parameters are derived in GIS and suitably classified 

into various units to ranks are assigned as given table below. 

Table 1 : Causative and forcing parameters weights and ranks  

 

Source: Musinguzi and Asiimwe, 2014  

More details about how to drive the above parameters and assign ranks is given below in the exercise. 
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Exercise 

The datasets generated to derive landslide susceptibility / hazard maps are described below. 

Slope: Slope is an important component in landslide susceptibility. Experience suggests that steeper 

slope contributes significantly to landslides. The slope map is derived using the SRTM digital elevation 

model at 90 m and it is classified into 0-12%, 12-25%, 25 – 50% and more than 50% and ranks are 

assigned as given the table above. 

● Open the existing ArcMap project (workspace) “UG_Landslide.mxd” stored on: 

X:\UG_Data\Module3\Landslide\Input\Workspace\ 

·   Check the input data given above, in Table of Contents (TOC). 

·   Bring up Arctoolbox by clicking the button 

·   Go to Spatial Analyst Tools > Surface > Slope 

·   Select the Input Raster “UG_DEM.tif” from the following location: 

 X:\UG_data\Module3\Landslide\Input\Raster\ 

·   Select the Output Raster “Slope_per.tif” in the following location: 

 X:\UG_data\Module3\Landslide\Output\Raster\ 

·    Select the “PERCENT_RISE” for Output measurement (optional) 

·   Click OK 

 
 

Classify the slope map into 4 classes of 0-12%, 12-25%, 25 – 50% and more than 50% and assign the 

weights of 1 to 4, as given in the table above. 

● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Reclass > Reclassify 



 

 

134 
 

 

·   In Reclassify window, Select the Input Raster “Slope_per.tif” from the location: 

 X:\UG_data\Module3\Landslide\Output\Raster\ 

● Select VALUE as reclass field 

● In the Reclassification part, select classify. 

● In Classification window, select Manual for the method and for classes select 4. 

● For Break Values, enter 12, 25, 50. 

·    Select the Output Raster “Slope_reclas.tif” in the following location: 

 X:\UG_data\Module3\Landslide\Output\Raster\ 

 

 
 

The reclassified slope map will be like this.  
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Soil Texture: Soil data used is FAO Harmonized Global soil data. Top soil texture information is available 

as attribute T_Texture which represents clayey (fine), loamy (medium) and sandy (coarse) soils and Not 

suitable (water). As part of preparation of this dataset, the textural classes were reclassified to reflect the 

different levels of texture for affecting landslide susceptibility. The four classes assigned scores 1 to 4: 

coarse (2), medium (3), fine (4) and not suitable (1), to reflect the importance of each soli class in 

determining the susceptibility to landslides. 

The soil texture map is given to you as UG_SoilT.tif for use and is shown below.   
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Vegetation / Land Cover: The Vegetation / land cover data set used is extracted from the regional (Africa) 

archive of Global land cover (raster). It has been post-processed to generate a vector version at national 

extent with the LCCS regional legend (46 classes), aggregated to 6 classes: Agriculture (AG), Barren Area 

(BA), Natural Vegetation Terrestrial (NVT), Natural Vegetation Aquatic (NVW), Urban Areas (UR) and 

Water Bodies (WAT).More details are available at  

http://www.fao.org/geonetwork/srv/en/metadata.show?currTab=simple&id=38184. 

The above land use classes are re-grouped into four classes: bare ground (BA), low dense vegetation 

(AG), fairly dense vegetation (NVW) and dense vegetation (NVT) and are assigned ranks of 1 to 4 

respectively. 

● Bring up Arctoolbox by clicking the button 

● Using the Conversion Tools > To Raster > Polygon to Raster. 

● Select the Input Features “UG_Landuse” from the following location: 

         X:\UG_data\Module3\Landslide\Input\Vector\ 

●  Select Field “Rank” (Landslide susceptibility rank for each land use class). 

● Select Output Raster “Lulc_Rank.tif” in the following location 

X:\UG_Data\Module3\Landslide\Output\Raster\ 

● Select Output Cell size (optional) “Slopeper.tif” or any other map from output folder 

http://www.fao.org/geonetwork/srv/en/metadata.show?currTab=simple&id=38184
http://www.fao.org/geonetwork/srv/en/metadata.show?currTab=simple&id=38184


 

 

137 
 

 

● Click OK 

Lulc_Rank map should look like as given below.  

 
 

Population: The population data used is from World Pop, which consists of number of people at 100 m 

resolution. More details are available at https://www.worldpop.org/doi/10.5258/SOTON/WP00283. 

  

The number of population for 100 m resolution in Uganda range from 0 to 1043. The population data is 

classified into 5 classes and ranks are assigned as given in the table below. 

 

 

  

https://www.worldpop.org/doi/10.5258/SOTON/WP00283
https://www.worldpop.org/doi/10.5258/SOTON/WP00283
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Number of Population Rank 

0 - 9 1 

10 - 99 2 

100 - 999 3 

1000 - 1043 4 

● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Reclass > Reclassify 

·   In Reclassify window, Select the Input Raster “UGA_WorldPop2015.tif” from the location: 

X:\UG_data\Module3\Landslide\Input\Raster\ 

● Select VALUE as reclass field 

● In the Reclassification part, select classify. 

● In Classification window, select Manual for the method and for classes select 4. 

● For Break Values, enter 9, 99, 999 and 1042.38. 

·    Select the Output Raster “Pop_reclas.tif” in the following location: 

 X:\UG_data\Module3\Landslide\Output\Raster\ 
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Landslide Susceptibility: The geo-spatial maps of the parameters i.e. slope, soil texture, vegetation / 

land use and population which are ranked based on their influence on landslide susceptibility are 

combined using the weights given below. 

  

Parameter Weight 

Slope 1 

Soil Texture 0.464 

Vegetation / Land use 0.12 

Population 0.128 

  

  

● Go to Spatial Analyst Tools > Overlay > Weighted  Sum 

● In Weighted Sum window, add all the parameters maps and their weights given in the table 

above. 

● Select the Output Raster “LSSusep.tif” in the following location 

X:\UG_Data\Module3\Landslide\Output\Raster\ 

 
 

● LSSusep.tif  map should look like as given below. 
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Forcing parameter:  Rainfall 

  

Rainfall data considered in this exercise is the long term annual rainfall during 1981 to 2010. This rainfall 

data was in 0.05 x 0.05 degree resolution (approximately 5 Km). The minimum rainfall was 530 mm and 

maximum rainfall was 2414 mm. The rainfall data is resampled to 90 m, same as the other geo-spatial 

datasets.  The rainfall data is reclassified into 5 classes and the ranks are assigned as given in the table 

below.  

 

Range of Rainfall (mm) Rank 

530 – 931 0.8 

931 – 1267 1.0 

1267 – 1603 1.2 
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1603 – 1939 1.4 

1939 – 2414 1.6 

 

● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Reclass > Reclassify 

·   In Reclassify window, Select the Input Raster “UGRain.tif” from the location: 

 X:\UG_data\Module3\Landslide\Input\Raster\ 

● Select VALUE as reclass field 

● In the Reclassification part, select classify. 

● In Classification window, select Manual for the method and for classes select 5. 

● For Break Values, enter 931, 1267, 1603, 1939 and 2414.  

 The classification window, in which range of rainfall is to be entered is shown below.  

 
 

·   Select the Output Raster “UG_RainRank.tif” in the following location: 

 X:\UG_data\Module3\Landslide\Output\Raster\ 

   

The classified RainRank map is shown below.  
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Landslide Hazard 

  

The landslide susceptibility and the rainfall map are combined to final landslide hazard 

map using the overlay tool in spatial analysis.  
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Use “UG_LSHazard.tif” as final landslide hazard map, which is shown below.  

 

 
 

As you observe the minimum and maximum values of landslide hazard score is 2.392 and 7.864. For 

better visualization, let us reclassify it into 3 classes (low, moderate and high) using the limits given 

below. 

Range of Hazard Score Hazard Class 

6.0 - 7.864 High 

4.0 – 6.0 Moderate 

2.392 – 4.0 Low 

Note: The classification ranges are subjective. Share your field experience in deciding them. 
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● Use the above range of landslide hazard index scores to classify the landslide hazard map of 

Uganda using Raster Calculator. 

● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Map Algebra > Raster Calculator. 

● In Raster Calculator Expression window, write the expression (use the available functional 

tools) given below. 

  

 Con(“UG_LSHazard.tif” <= 4.0, 1, Con(“UG_LSHazard.tif” >= 6.0, 3,2)) 

●  Select Output Raster “UG_LSH_cls.tif” in the following location 

X:\UG_Data\Module3\Landslide\Output\Raster\ 

● Click OK. 

The classified landslide hazard map of Uganda is given below. 
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Which sub-district in Uganda has highest landslide hazard?   

● Let us now assess the mean landslide hazard score within each sub-district (Admin 3). 

● Bring up Arctoolbox by clicking the button 

● Go to Spatial Analyst Tools > Zonal > Zonal Statistics as Table. 

● Select the Input Raster or Feature Zone Data “UG_Admin3” from the following location: 

 X:\UG_Data\Module3\Landslide\FFPI\Input\Vector\ 

● Select Zone Field “Admin3Name” 

Select the Input Value Raster “UG_LSHazard.tif ” in the following location: 

X:\UG_Data\Module3\ Landslide\Output\Raster\ 

● Select the Output Table “Mean_LSH_Admin3” in the following location: 

 X:\UG_Data\Module3\Landslide\Output\ 

  

●  Select Statistics Type (optional) “MEAN” 

● Click OK. 

● Open the Table “Mean_ LSH _Admin3” to see the Mean landslide hazard value for each sub-

district in the field “MEAN”. 

● Analyse the table “Mean_ LSH _Admin3” and answer the following questions. 

  

Questions 

  

1.    In which sub-district the mean landslide hazard  score is highest?   

        ______________________________________________________________________ 

  

2.    In how many sub-districts the mean landslide hazard score is more than 6.0? 

  

______________________________________________________________________ 
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3.3 Hazard Monitoring and Multi-hazard Early Warning Systems  

The topics, concepts, and techniques covered under module three above are very important inputs to 

hazard monitoring. Some of the major disasters in the Greater Horn of Africa region are slow onset 

disasters like drought and some others have rapid onset like earthquake and to some extent floods. If 

DRM institutions have the capacity to identify major disasters, put in place key indicators and set 

thresholds and finally monitor indicators at a certain time interval, this definitely contribute to a significant 

reduction in loss of life and damage to property. The opportune time to put in place all the preparedness, 

mitigation and response plans is the time before a disaster strikes. It is far cheaper to invest in 

preparedness, mitigation and resilience building as compared to investment required to respond to and 

rebuild after a disaster. From the historical disaster data and experience of the region, disaster is ‘a matter 

of when and not if’ indicating the need to put in place functional mechanisms to disaster risk reduction. 

One of such an important mechanisms to DRR is to put in place hazard monitoring and early warning 

systems. Under this section we will be discussing a GIS based techniques for monitoring two of the major 

disasters in the region, droughts and floods at a different time scale. 

 
3.3.1 Drought Monitoring for Early Warning 

Key indicators and thresholds for drought monitoring 

There are several indicators and indices to drought monitoring and a reading material from World 

Meteorological Organization (WMO) is provided for your reference under C/DATA/Module3/DRM 

readings folder. For this training very relevant global experiences on drought monitoring will be presented 

and we will limit ourselves to selected few, leaving the option for you to explore further. The following 

table summarizes some selected examples of drought hazard indicators and monitoring from different 

parts of the world. 
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Type of 
Drought 

Key indicator(s) Institution Web page 

Combined 
Drought 

SPI, VHI, Water 
level, temp., soil 

moisture, field data 

National Drought 
Mitigation Center 
(USA) 

http://drought.unl.edu/Home.aspx 

Combined 
Drought 
Indicator (CDI) 

SPI, Soil moisture, 
vegetation anomaly, 
snow pack, river 
discharge 

European 
Drought 
Observatory - 
Joint Research 
Center 

edo.jrc.ec.europa.eu/edov2/php/index.php?id=1000 

Meteorological, 
agricultural 

SPI, soil moisture, 
drought severity 
index 

The South Asia 
Drought 
Monitoring 
System 
(SADMS) 

http://dms.iwmi.org/app/ 

 

Meteorological, 
agricultural, 
hydrological 

SPI, stream flow, 
vegetation, and 
many others 

Princeton 
University: 
African drought & 
flood monitor 

http://stream.princeton.edu/AWCM/WEBPAGE/interfa
ce.php?locale=en 

 

Meteorological, 
agricultural 

SPI, vegetation 
anomaly/condition 

ICPAC: 

Drought Watch 

https://icpac.maps.arcgis.com/apps/CompareAnalysis/ 
index.html?appid=622cfedde5304661bf606eacaa65d
7dc 

 
Seasonal and Monthly Drought Monitoring 

One of the key point in hazard monitoring is to decide the time scale which depends on nature of the 

hazard, temporal resolution required, objectives of the monitoring, in addition to many other factors. For 

drought monitoring for instance the common time scales are dekadal (10 days), monthly and seasonal. 

For our case we will limit our exercises to monthly and seasonal monitoring of drought for selected 

seasons in 2017. In hazard monitoring a threshold value or a reference year/ state/layer is compared with 

   

http://drought.unl.edu/Home.aspx
http://dms.iwmi.org/app/
http://stream.princeton.edu/AWCM/WEBPAGE/interface.php?locale=en
http://stream.princeton.edu/AWCM/WEBPAGE/interface.php?locale=en
https://icpac.maps.arcgis.com/apps/CompareAnalysis/
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the season under consideration. The anomaly or difference of these two values can be calculated in one 

of the three ways. These are absolute difference (current – reference), relative difference (current – 

reference/reference) and standardized difference (current-reference/standard deviation). 

For the purpose of demonstration and exercise, we run seasonal anomaly based drought monitoring 

(meteorological drought). For that we will follow these procedures: 

● Choose your season for your country 

● Prepare seasonal total rainfall data for climatological years (1981-2010) WMO 

● Calculate Long Term Average (LTA) of your data 

● Subtract the Long term average from March to May2017 data (MAM2017 – LTA) 

=Absolute difference 

● Set the result in to reasonable classes to see the areas receiving excess and 

deficit for the season as compared to long term average or a reference year. 

NOTICE: 

● For monthly monitoring you need to calculate monthly long term average for 

all the twelve months and calculate the anomaly. 

● For monitoring rainfall and vegetation anomaly you can also 

consider calculating standardized difference (Current – Long term 

average/Standard Deviation) 

● Monitoring of drought requires monitoring anomaly at decadal, monthly, 

seasonal scales depending on your needs 

This is monthly vegetation anomaly map produced in the same way as rainfall anomaly. 

 
 

3.3.2 Multi-hazard Early Warning Systems 

Early Warning Systems (EWS) is defined as: 

“The set of capacities needed to generate and disseminate timely and meaningful warning information to 

enable individuals, communities and organizations threatened by a hazard to prepare and to act 

appropriately and in sufficient time to reduce the possibility of harm or loss.” (UNISDR, 2009) 

Traditionally, many countries have been reactive to disasters experiencing significant losses in lives and 

livelihoods of their citizens. Adoption of the Hyogo Framework for Action (HFA) 2005–2015 by 168 

http://www.wmo.int/pages/prog/drr/resourceHFA_en.html
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countries has led to a paradigm shift in disaster risk management from emergency response to a 

comprehensive approach which also includes preparedness and preventive strategies to reduce risk, 

according to WMO. The current Sendai framework (2015-2030) also stressed the need for multi- hazard 

early warning system by placing it as one of the seven goals for an effective disaster risk reduction. The 

first of the four priority of the Sendai Framework is understanding risk which by implication is about hazard 

assessment, monitoring and early warning to an effective understanding of risk and put all the necessary 

mechanisms to prepare, prevent, mitigate and effectively responded to disaster risks. 

Early Warning Systems (EWS) are well recognized as a critical life-saving tool for floods, droughts, 

storms, bush fires, and other hazards. The recorded economic losses linked to extreme hydro- 

meteorological events have increased nearly 50 times over the past five decades, but the global loss of 

life has decreased significantly, by a factor of about 10, thus saving millions of lives over this period. This 

has been attributed to better monitoring and forecasting of hydro-meteorological hazards and more 

effective emergency preparedness, according to WMO report. 

From their practice and experience, WMO identified ten common principles that have led to the success 

of Early warning systems, irrespective of the political, social, institutional, and economic factors in each 

country. 

Political recognition. There is a strong political recognition of the benefits of early warning systems, 

reflected in harmonized national and local disaster risk management policies, planning, legislation and 

budgeting 

Common operational components. Each effective system is built upon four components: hazard 

detection, monitoring and forecasting; risk analysis and incorporation of risk information in emergency 

planning and warnings; dissemination of timely and authoritative warnings; and community planning and 

preparedness with the ability to activate emergency plans to prepare and respond, coordinated across 

agencies at national to local levels. 

Role clarification. Stakeholders are identified, their roles and responsibilities and coordination 

mechanisms are clearly defined and then they are documented within national and local plans, legislation, 

directives and memoranda of understanding, including those of technical agencies such as National 

Meteorological and Hydrological Services. 

Resource allocation. EWS capacities are supported by adequate resources (human, financial, 

equipment, etc.) across national and local levels, and the system is designed and implemented for long-

term sustainability. 

Risk assessment. Hazard, exposure and vulnerability information are used to carry out risk assessments 

at different levels, as critical input into emergency planning and development of warning messages. 

Appropriate warnings. Warning messages are: clear, consistent and include risk information; designed 

to link threat levels to emergency preparedness and response actions (using color, flags, etc.); 

understood by authorities and the population; and issued from a single (or unified), recognized and 

authoritative source. 

Timely dissemination. Warning dissemination mechanisms are able to reach the authorities, other 

stakeholders and the population at risk in a timely and reliable fashion. 

Integration into response planning. Emergency response plans are developed with consideration for 

hazard/risk levels, characteristics of the exposed communities (urban, rural, ethnic populations, tourists 
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and particularly vulnerable groups such as children, the elderly and the hospitalized), coordination 

mechanisms and various stakeholders. 

Integration in relevant educational programme. Training in risk awareness, hazard recognition and 

related emergency response actions is integrated in various formal and informal educational programme 

and linked to regularly conducted drills and tests across the system to ensure operational readiness at 

any time. 

Feedback. Effective feedback and improvement mechanisms are in place at all levels to provide 

systematic evaluation and ensure system improvement over time. 

A concept note document by UNISDR also recognized early warning as an effective approach for 

reducing disaster risk and the loss of life. There has been a paradigm shift from single hazard to multi- 

hazard early warning and from providing hazard information to providing risk and impact information. 

However, there are gaps in effective implementation of people-centered, multi-hazard warning systems. 

In addition, risk knowledge and impact information are often not at all, or insufficiently, integrated into 

multi-hazard early warning systems. 

The development and hosting of a multi-hazard early warning system for your institution requires all the 

technical skills covered under the previous modules of this training, in addition to other capacities like 

hardware, resources and so on. However, it is very important to stress the importance of key issues to a 

successful early warning system like institutions in disaster governance, multi-sector working group(s), 

community participation, selection of appropriate methodology/technology, mainstreaming to major 

sectors, partnerships (Government, Non-Governmental actors, Private sector, and Research and Higher 

learning institutions. …etc.) and others. 
 

 
 
A functional and end-to-end early warning system requires addressing the following four key components 

according to a training material obtained from ADPC. Each of these blocks require detailed planning and 

expertise. 

  

S
tation Earth 

Observation & 
other 



 

 

151 
 

 

 

 
                                                                                  Source: ADPC  

 

However, do not forget to start with what you already have in place. One of the good practices in 

developing early warning is to understand the major hazards in your country, compiling data from earth 

observation and data from the different sectoral ministries and non-governmental offices relevant and 

related to hazards and risk.

3.3.3 Components of Early Warning System 

There are four components needed for an effective early warning: Detection, monitoring and 

forecasting the hazards; Analyses of risks involved; Dissemination of timely warnings - which 

should carry the authority of government; Activation of emergency plans to prepare and respond. 

These four components need to be coordinated across many agencies at national to local levels for the 

system to work. Failure in one component or lack of coordination across them could lead to the failure of 

the whole system. The issuance of warnings is a national responsibility; thus, roles and responsibilities 

of various public and private sector stakeholders for implementation of EWS should be clarified and 

reflected in the national to local regulatory frameworks, planning, budgetary, coordination, and 

operational mechanisms. 

Component 1: Detection, monitoring and forecasting the hazards 

The first part of Module 3 of this training material covers detailed techniques, concepts and steps in 

hazard assessment which is meant to detect and identify the hazards. It is this assessment and baseline 

data that will constitute the monitoring of hazards based on indicators and thresholds we set for certain 

geographical area, as discussed under Module 3. Forecasting parameters like rainfall helps to give good 

lead time for preparedness and mitigation of the impending disaster but also helps to mobilize resource 

for response. 
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Monitoring based Drought early warning Model based flood early 

warning 

 

Measurement/model based flood early warning (Bangladesh, http://www.ffwc.gov.bd/?id=riv) 

Component 2: Analysis of risks involved 

Detailed data on what we call “elements at risk” is used to map the scope and extents of the risk involved 

during a disaster. In flood hazard and risk assessment, for instance, once all the extent and severity of 

the flood is identified the next step is to overlay elements at risk which includes settlement areas, key 

infrastructure, crop fields, key grazing areas…etc. The choice of the elements at risk depends on the 

nature and magnitude of the hazard, objective of your risk assessment, data availability and other factors 

to mapping risk. Once you are able to produce risk maps and able to validate the final product you should 

clearly see the elements at risk and level of risks involved. Based on this information, you should be able 

to produce early warning information aimed at taking actions that would reduce the risk, mitigate the 

impacts, or build the resilience capacity of the communities at risk. Your early warning information 

contains several layers of information but needs to be clear on the type and level of risks involved (to life, 

property…etc) with coverage/location information, guideline on what to do for the responders (the 

community is the first responder), and so on. The experiences from early warning systems and practices 

reveals the strong need for people centered early warning systems. 

Component 3: Dissemination of timely warnings 

One of the main features of early warning is timeliness. The more time we give the warning the better for 

planning and preparation. The dissemination of early warning information can use different stages and 

platforms. Some of these platforms can be summarized as follows; automatic or manual alarms, text 

messages, email groups, activation of emergency systems, high level meetings…etc. depending on the 

nature (quick onset or slow onset) of the disaster. 

  

http://www.ffwc.gov.bd/?id=riv
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Component 4: Activation of emergency plans to prepare and respond 

This is the critical stage of the early warning system where inaction or delayed action in the faces of 

looming hazard would result in loss of life and damage to property. Timely early warning system helps to 

activate an emergency plan well in time which in turn allows for sufficient time to prepare and effectively 

respond to a disaster. 

3.3.4 Monitoring and Forecast Based Early Warning Systems 

Monitoring based early warning systems 

The advantage of monitoring based early warning system (EWS), as compared to forecast based EWS 

is its higher level of confidence and lesser uncertainty. However, monitoring requires continuous follow 

up of the situation starting with historical records. 
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Source: Saifeldin Abdulrahman and Ahmed Amdihun, 2017 

3.3.5 Forecast based early warning systems 

The forecast based early warning system, in this context refers to a situation where daily, decadal, 

monthly or seasonal forecast of input parameter is used to deduce about a future situation or develop a 

future scenario. For instance, ICPAC produces seasonal forecast of rainfall and temperature and if a 

rainfall anomaly is calculated based on this forecast, we can qualify this as forecast based early warning. 

However, it is important to note that both monitoring and forecast based early warning might not have 

clear boundary as both might use models and predictors or indices. 
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The GHACOF exercise you finalized over the last two days is a forecast based early warning system 

which mainly bases on expert opinion and consensus on what to expect for the coming season. 
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STEP (17) 

3.4 Flood Monitoring and Early Warning 

Many of low land areas are prone to flooding than highlands, the establishment of flood warning systems 

near any major waterway or body of water provides critical information that can protect property and save 

lives. Most effective flood warning methods extend beyond the installation of gages and telemetry 

equipment, and employ qualified staff and carefully designed procedures to provide the earliest warning 

about whether a flood should be expected, when it will occur, and how severe it will be. This guide offers 

instruction to individuals, communities, and organizations interested in establishing and operating flood 

warning systems. 

 

Flood Risk Early Warning 

An effective flood warning system is based on the regular collection of rainfall data within the basin, 

stream level, and stream flow data. This is achieved through routine monitoring using an automated 

communications process by which measurements and other data are collected at remote or inaccessible 

points and transmitted to receiving equipment for monitoring, and then disseminating the warning. 

Automated flood warning systems may utilize radio, mobile phones, or satellite telemetry to communicate 

with a host computer or network. Most used methods to disseminate the warning are Global System for 

Mobile Communications (GSM) and web-based flood monitoring system. 

Web-based flood monitoring system 

This section will highlight what ICPAC does at regional level in terms of flood early warning. Flood warning 

should be location based, specific in time and give the extent of coverage to assist timely actions to save 

lives and properties. 

 

 

   

Source: fondriest 
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The approach used at ICPAC 
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Interaction with ICPAC web-based platform (underdevelopment) 

 

 
 

 
You can interact with the portal from the link: 41.215.21.156 

 

 
 

 

Reference: 

Zogg Jeffrey and Kevin Deitsch, 2013. The Flash Flood Potential Index at WFO Des Moines, Iowa, NOAA 

and National Weather Service Report.  

 

  

  

  

Dissemination portal – Mike operations (Underdevelopment) 
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4 Final Group Exercises (Floods and Droughts)  

4.1.1 Group Exercise on Flood / Drought:   

Task: Design and Implementation of Flood / Drought Risk using EO Data   

The participants in each group should discuss among themselves and come out of with 

answers / make a presentation for the following questions.  

 

1. Keeping in view of the flood/drought issues in Uganda design a Flood/Drought Risk 

Assessment plan using EO Data and other database. 

2. Develop a work plan to access / download the freely available and required data 

(satellite and GIS database) for Uganda.  

3. Generate a work plan for analysis of satellite data for flood / drought hazard 

assessment  

4. Develop a work plan for exposure assessment due to flood / drought hazard  

5. Develop strategy for vulnerability and risk assessment of exposed elements for flood / 

drought.  

6. Identify the suitable national institutions/departments/ organizations who can support 

the government in various components of risk assessment.  

7. Do you see any additional support / requirement to develop a national strategy for 

flood and drought risk assessment in Uganda?  


